summaryrefslogtreecommitdiffstats
path: root/python/python3/patches/python3.no-static-library.diff
diff options
context:
space:
mode:
author Audrius Kažukauskas <audrius@neutrino.lt>2017-08-20 15:23:23 +0300
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2017-08-26 07:20:44 +0700
commitedaed3d07af00bdf62aa1644d84e3d4ff23c2b15 (patch)
treea0c6f5a0b647edcc8066b86ba0a92f75a1da6f65 /python/python3/patches/python3.no-static-library.diff
parent335158d78e556a162674e1229784e77fa86c21c9 (diff)
downloadslackbuilds-edaed3d07af00bdf62aa1644d84e3d4ff23c2b15.tar.gz
slackbuilds-edaed3d07af00bdf62aa1644d84e3d4ff23c2b15.tar.xz
python/python3: Updated for version 3.6.2.
Signed-off-by: Audrius Kažukauskas <audrius@neutrino.lt>
Diffstat (limited to '')
-rw-r--r--python/python3/patches/python3.no-static-library.diff14
1 files changed, 7 insertions, 7 deletions
diff --git a/python/python3/patches/python3.no-static-library.diff b/python/python3/patches/python3.no-static-library.diff
index 2821ca79d0..cbdc676f7a 100644
--- a/python/python3/patches/python3.no-static-library.diff
+++ b/python/python3/patches/python3.no-static-library.diff
@@ -1,7 +1,7 @@
-diff -uar Python-3.6.0.orig/Makefile.pre.in Python-3.6.0/Makefile.pre.in
---- Python-3.6.0.orig/Makefile.pre.in 2016-12-23 04:21:21.000000000 +0200
-+++ Python-3.6.0/Makefile.pre.in 2016-12-27 22:50:14.139741226 +0200
-@@ -564,7 +564,7 @@
+diff -uar Python-3.6.2.orig/Makefile.pre.in Python-3.6.2/Makefile.pre.in
+--- Python-3.6.2.orig/Makefile.pre.in 2017-07-08 06:33:27.000000000 +0300
++++ Python-3.6.2/Makefile.pre.in 2017-08-20 15:03:55.591112188 +0300
+@@ -533,7 +533,7 @@
$(RUNSHARED) $(PYTHON_FOR_BUILD) ./Tools/clinic/clinic.py --make
# Build the interpreter
@@ -10,7 +10,7 @@ diff -uar Python-3.6.0.orig/Makefile.pre.in Python-3.6.0/Makefile.pre.in
$(LINKCC) $(PY_LDFLAGS) $(LINKFORSHARED) -o $@ Programs/python.o $(BLDLIBRARY) $(LIBS) $(MODLIBS) $(SYSLIBS) $(LDLAST)
platform: $(BUILDPYTHON) pybuilddir.txt
-@@ -609,18 +609,6 @@
+@@ -578,18 +578,6 @@
$(PYTHON_FOR_BUILD) $(srcdir)/setup.py $$quiet build
@@ -29,7 +29,7 @@ diff -uar Python-3.6.0.orig/Makefile.pre.in Python-3.6.0/Makefile.pre.in
libpython$(LDVERSION).so: $(LIBRARY_OBJS)
if test $(INSTSONAME) != $(LDLIBRARY); then \
$(BLDSHARED) -Wl,-h$(INSTSONAME) -o $(INSTSONAME) $(LIBRARY_OBJS) $(MODLIBS) $(SHLIBS) $(LIBC) $(LIBM) $(LDLAST); \
-@@ -710,7 +698,7 @@
+@@ -679,7 +667,7 @@
echo "-----------------------------------------------"; \
fi
@@ -38,7 +38,7 @@ diff -uar Python-3.6.0.orig/Makefile.pre.in Python-3.6.0/Makefile.pre.in
$(LINKCC) $(PY_LDFLAGS) $(LINKFORSHARED) -o $@ Programs/_testembed.o $(BLDLIBRARY) $(LIBS) $(MODLIBS) $(SYSLIBS) $(LDLAST)
############################################################################
-@@ -1388,18 +1376,6 @@
+@@ -1391,18 +1379,6 @@
else true; \
fi; \
done