summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Audrius Kažukauskas <audrius@neutrino.lt>2017-03-22 22:23:17 +0200
committer David Spencer <idlemoor@slackbuilds.org>2017-03-25 00:11:14 +0000
commitc05d955912924a83e618cbd02e88b387806b8f09 (patch)
tree7d2b7592820fb2f180cfdfa639bb836c3810a086 /python
parent912f5aa8046b1087f84c072bef911a9030b8ddc9 (diff)
downloadslackbuilds-c05d955912924a83e618cbd02e88b387806b8f09.tar.gz
slackbuilds-c05d955912924a83e618cbd02e88b387806b8f09.tar.xz
python/python3: Updated for version 3.6.1.
Signed-off-by: Audrius Kažukauskas <audrius@neutrino.lt>
Diffstat (limited to 'python')
-rw-r--r--python/python3/patches/python3.fix-comment-style.patch11
-rw-r--r--python/python3/patches/python3.x86_64.diff75
-rw-r--r--python/python3/python3.SlackBuild9
-rw-r--r--python/python3/python3.info6
4 files changed, 31 insertions, 70 deletions
diff --git a/python/python3/patches/python3.fix-comment-style.patch b/python/python3/patches/python3.fix-comment-style.patch
deleted file mode 100644
index 03a2ee3762..0000000000
--- a/python/python3/patches/python3.fix-comment-style.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- Python-3.6.0/Include/pyport.h.orig 2017-01-01 07:58:08.575202311 +0700
-+++ Python-3.6.0/Include/pyport.h 2017-01-01 07:58:20.332234160 +0700
-@@ -37,7 +37,7 @@
- * integral synonyms. Only define the ones we actually need.
- */
-
--// long long is required. Ensure HAVE_LONG_LONG is defined for compatibility.
-+/* long long is required. Ensure HAVE_LONG_LONG is defined for compatibility. */
- #ifndef HAVE_LONG_LONG
- #define HAVE_LONG_LONG
- #endif
diff --git a/python/python3/patches/python3.x86_64.diff b/python/python3/patches/python3.x86_64.diff
index d6201b4db3..182fc62932 100644
--- a/python/python3/patches/python3.x86_64.diff
+++ b/python/python3/patches/python3.x86_64.diff
@@ -1,6 +1,6 @@
-diff -uar Python-3.6.0.orig/Lib/distutils/command/install.py Python-3.6.0/Lib/distutils/command/install.py
---- Python-3.6.0.orig/Lib/distutils/command/install.py 2016-12-23 04:21:19.000000000 +0200
-+++ Python-3.6.0/Lib/distutils/command/install.py 2016-12-27 23:23:09.347324233 +0200
+diff -uar Python-3.6.1.orig/Lib/distutils/command/install.py Python-3.6.1/Lib/distutils/command/install.py
+--- Python-3.6.1.orig/Lib/distutils/command/install.py 2017-03-21 08:32:38.000000000 +0200
++++ Python-3.6.1/Lib/distutils/command/install.py 2017-03-22 21:42:23.915962369 +0200
@@ -29,15 +29,15 @@
INSTALL_SCHEMES = {
@@ -21,9 +21,9 @@ diff -uar Python-3.6.0.orig/Lib/distutils/command/install.py Python-3.6.0/Lib/di
'headers': '$base/include/python/$dist_name',
'scripts': '$base/bin',
'data' : '$base',
-diff -uar Python-3.6.0.orig/Lib/distutils/sysconfig.py Python-3.6.0/Lib/distutils/sysconfig.py
---- Python-3.6.0.orig/Lib/distutils/sysconfig.py 2016-12-23 04:21:19.000000000 +0200
-+++ Python-3.6.0/Lib/distutils/sysconfig.py 2016-12-27 23:23:45.371557745 +0200
+diff -uar Python-3.6.1.orig/Lib/distutils/sysconfig.py Python-3.6.1/Lib/distutils/sysconfig.py
+--- Python-3.6.1.orig/Lib/distutils/sysconfig.py 2017-03-21 08:32:38.000000000 +0200
++++ Python-3.6.1/Lib/distutils/sysconfig.py 2017-03-22 21:42:23.915962369 +0200
@@ -133,7 +133,7 @@
if os.name == "posix":
@@ -33,9 +33,9 @@ diff -uar Python-3.6.0.orig/Lib/distutils/sysconfig.py Python-3.6.0/Lib/distutil
if standard_lib:
return libpython
else:
-diff -uar Python-3.6.0.orig/Lib/site.py Python-3.6.0/Lib/site.py
---- Python-3.6.0.orig/Lib/site.py 2016-12-23 04:21:19.000000000 +0200
-+++ Python-3.6.0/Lib/site.py 2016-12-27 23:24:50.123773461 +0200
+diff -uar Python-3.6.1.orig/Lib/site.py Python-3.6.1/Lib/site.py
+--- Python-3.6.1.orig/Lib/site.py 2017-03-21 08:32:38.000000000 +0200
++++ Python-3.6.1/Lib/site.py 2017-03-22 21:42:23.915962369 +0200
@@ -304,7 +304,7 @@
seen.add(prefix)
@@ -45,9 +45,9 @@ diff -uar Python-3.6.0.orig/Lib/site.py Python-3.6.0/Lib/site.py
"python%d.%d" % sys.version_info[:2],
"site-packages"))
else:
-diff -uar Python-3.6.0.orig/Lib/sysconfig.py Python-3.6.0/Lib/sysconfig.py
---- Python-3.6.0.orig/Lib/sysconfig.py 2016-12-23 04:21:19.000000000 +0200
-+++ Python-3.6.0/Lib/sysconfig.py 2016-12-27 23:27:39.368563068 +0200
+diff -uar Python-3.6.1.orig/Lib/sysconfig.py Python-3.6.1/Lib/sysconfig.py
+--- Python-3.6.1.orig/Lib/sysconfig.py 2017-03-21 08:32:38.000000000 +0200
++++ Python-3.6.1/Lib/sysconfig.py 2017-03-22 21:42:23.916962405 +0200
@@ -20,10 +20,10 @@
_INSTALL_SCHEMES = {
@@ -93,9 +93,9 @@ diff -uar Python-3.6.0.orig/Lib/sysconfig.py Python-3.6.0/Lib/sysconfig.py
'include': '{userbase}/include/python{py_version_short}',
'scripts': '{userbase}/bin',
'data': '{userbase}',
-diff -uar Python-3.6.0.orig/Makefile.pre.in Python-3.6.0/Makefile.pre.in
---- Python-3.6.0.orig/Makefile.pre.in 2016-12-23 04:21:21.000000000 +0200
-+++ Python-3.6.0/Makefile.pre.in 2016-12-27 23:28:09.024577604 +0200
+diff -uar Python-3.6.1.orig/Makefile.pre.in Python-3.6.1/Makefile.pre.in
+--- Python-3.6.1.orig/Makefile.pre.in 2017-03-21 08:32:38.000000000 +0200
++++ Python-3.6.1/Makefile.pre.in 2017-03-22 21:42:23.916962405 +0200
@@ -131,7 +131,7 @@
MANDIR= @mandir@
INCLUDEDIR= @includedir@
@@ -105,9 +105,9 @@ diff -uar Python-3.6.0.orig/Makefile.pre.in Python-3.6.0/Makefile.pre.in
ABIFLAGS= @ABIFLAGS@
# Detailed destination directories
-diff -uar Python-3.6.0.orig/Modules/getpath.c Python-3.6.0/Modules/getpath.c
---- Python-3.6.0.orig/Modules/getpath.c 2016-12-23 04:21:21.000000000 +0200
-+++ Python-3.6.0/Modules/getpath.c 2016-12-27 23:30:11.883780781 +0200
+diff -uar Python-3.6.1.orig/Modules/getpath.c Python-3.6.1/Modules/getpath.c
+--- Python-3.6.1.orig/Modules/getpath.c 2017-03-21 08:32:38.000000000 +0200
++++ Python-3.6.1/Modules/getpath.c 2017-03-22 21:42:23.917962441 +0200
@@ -494,7 +494,7 @@
_pythonpath = Py_DecodeLocale(PYTHONPATH, NULL);
_prefix = Py_DecodeLocale(PREFIX, NULL);
@@ -135,10 +135,10 @@ diff -uar Python-3.6.0.orig/Modules/getpath.c Python-3.6.0/Modules/getpath.c
}
/* If we found EXEC_PREFIX do *not* reduce it! (Yet.) */
-diff -uar Python-3.6.0.orig/configure Python-3.6.0/configure
---- Python-3.6.0.orig/configure 2016-12-23 04:21:22.000000000 +0200
-+++ Python-3.6.0/configure 2016-12-27 23:31:34.568609672 +0200
-@@ -14896,9 +14896,9 @@
+diff -uar Python-3.6.1.orig/configure Python-3.6.1/configure
+--- Python-3.6.1.orig/configure 2017-03-21 08:32:38.000000000 +0200
++++ Python-3.6.1/configure 2017-03-22 21:42:23.920962550 +0200
+@@ -14963,9 +14963,9 @@
if test x$PLATFORM_TRIPLET = x; then
@@ -150,9 +150,9 @@ diff -uar Python-3.6.0.orig/configure Python-3.6.0/configure
fi
-diff -uar Python-3.6.0.orig/setup.py Python-3.6.0/setup.py
---- Python-3.6.0.orig/setup.py 2016-12-23 04:21:22.000000000 +0200
-+++ Python-3.6.0/setup.py 2016-12-27 23:34:22.210345509 +0200
+diff -uar Python-3.6.1.orig/setup.py Python-3.6.1/setup.py
+--- Python-3.6.1.orig/setup.py 2017-03-21 08:32:38.000000000 +0200
++++ Python-3.6.1/setup.py 2017-03-22 21:47:59.638077062 +0200
@@ -491,7 +491,7 @@
# directories (i.e. '.' and 'Include') must be first. See issue
# 10520.
@@ -162,28 +162,3 @@ diff -uar Python-3.6.0.orig/setup.py Python-3.6.0/setup.py
add_dir_to_list(self.compiler.include_dirs, '/usr/local/include')
# only change this for cross builds for 3.3, issues on Mageia
if cross_compiling:
-@@ -782,11 +782,11 @@
- elif curses_library:
- readline_libs.append(curses_library)
- elif self.compiler.find_library_file(lib_dirs +
-- ['/usr/lib/termcap'],
-+ ['/usr/lib64/termcap'],
- 'termcap'):
- readline_libs.append('termcap')
- exts.append( Extension('readline', ['readline.c'],
-- library_dirs=['/usr/lib/termcap'],
-+ library_dirs=['/usr/lib64/termcap'],
- extra_link_args=readline_extra_link_args,
- libraries=readline_libs) )
- else:
-@@ -823,8 +823,8 @@
- if krb5_h:
- ssl_incs += krb5_h
- ssl_libs = find_library_file(self.compiler, 'ssl',lib_dirs,
-- ['/usr/local/ssl/lib',
-- '/usr/contrib/ssl/lib/'
-+ ['/usr/local/ssl/lib64',
-+ '/usr/contrib/ssl/lib64/'
- ] )
-
- if (ssl_incs is not None and
diff --git a/python/python3/python3.SlackBuild b/python/python3/python3.SlackBuild
index 62f93e34a2..4b1717187f 100644
--- a/python/python3/python3.SlackBuild
+++ b/python/python3/python3.SlackBuild
@@ -24,9 +24,9 @@
PRGNAM=python3
SRCNAM=Python
-VERSION=${VERSION:-3.6.0}
+VERSION=${VERSION:-3.6.1}
BRANCH_VERSION=$(echo $VERSION | cut -f 1,2 -d . )
-BUILD=${BUILD:-3}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -72,9 +72,6 @@ patch -p1 -i $CWD/patches/python3.readline.set_pre_input_hook.diff
# We don't want a large libpython*.a.
patch -p1 -i $CWD/patches/python3.no-static-library.diff
-# Change comment style from C++ to C, which fixes building pygobject3-python3.
-patch -p1 -i $CWD/patches/python3.fix-comment-style.patch
-
if [ "$ARCH" = "x86_64" ]; then
# Install to lib64 instead of lib.
patch -p1 -i $CWD/patches/python3.x86_64.diff
@@ -128,7 +125,7 @@ find $PKG -type f -perm 555 -exec chmod 755 '{}' \;
# Install docs.
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a README LICENSE Misc $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README.rst LICENSE Misc $PKG/usr/doc/$PRGNAM-$VERSION
mv $SITEPK/README $PKG/usr/doc/$PRGNAM-$VERSION/README.python-tools
( cd $PKG/usr/doc/$PRGNAM-$VERSION ; ln -sf $TOOLSDIR Tools )
if [ -e "$CWD/python-$VERSION-docs-html.tar.bz2" ]; then
diff --git a/python/python3/python3.info b/python/python3/python3.info
index f9dff19adc..cf66871816 100644
--- a/python/python3/python3.info
+++ b/python/python3/python3.info
@@ -1,8 +1,8 @@
PRGNAM="python3"
-VERSION="3.6.0"
+VERSION="3.6.1"
HOMEPAGE="https://www.python.org/"
-DOWNLOAD="https://www.python.org/ftp/python/3.6.0/Python-3.6.0.tar.xz"
-MD5SUM="82b143ebbf4514d7e05876bed7a6b1f5"
+DOWNLOAD="https://www.python.org/ftp/python/3.6.1/Python-3.6.1.tar.xz"
+MD5SUM="692b4fc3a2ba0d54d1495d4ead5b0b5c"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""