summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Steven Voges <svoges.sbo@gmail.com>2023-03-11 21:44:38 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2023-03-11 21:45:00 +0700
commit79422f776e715bba00260cfee757856dfd008eaf (patch)
tree159766d7c445239bc59f1bc50d7e731d62adf8f1 /python
parent9a0cb3215cd4455e43415d49cd4d3765c5962b49 (diff)
downloadslackbuilds-79422f776e715bba00260cfee757856dfd008eaf.tar.gz
slackbuilds-79422f776e715bba00260cfee757856dfd008eaf.tar.xz
python/python3-puremagic: Added (Python file identification).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/python3-puremagic/README24
-rw-r--r--python/python3-puremagic/python3-puremagic.SlackBuild96
-rw-r--r--python/python3-puremagic/python3-puremagic.info10
-rw-r--r--python/python3-puremagic/slack-desc19
4 files changed, 149 insertions, 0 deletions
diff --git a/python/python3-puremagic/README b/python/python3-puremagic/README
new file mode 100644
index 0000000000..1835595d3e
--- /dev/null
+++ b/python/python3-puremagic/README
@@ -0,0 +1,24 @@
+puremagic is a pure python module that will identify a file based off
+it's magic numbers.
+
+It is designed to be minimalistic and inherently cross platform
+compatible. It is also designed to be a stand in for python-magic, it
+incorporates the functions from_file(filename[, mime]) and
+from_string(string[, mime]) however the magic_file() and magic_string()
+are more powerful and will also display confidence and duplicate
+matches.
+
+It does NOT try to match files off non-magic string. In other words it
+will not search for a string within a certain window of bytes like
+others might.
+
+Advantages over using a wrapper for 'file' or 'libmagic':
+ * Faster
+ * Lightweight
+ * Cross platform compatible
+ * No dependencies
+
+Disadvantages:
+ * Does not have as many file types
+ * No multilingual comments
+ * Duplications due to small or reused magic numbers
diff --git a/python/python3-puremagic/python3-puremagic.SlackBuild b/python/python3-puremagic/python3-puremagic.SlackBuild
new file mode 100644
index 0000000000..561dfe31d4
--- /dev/null
+++ b/python/python3-puremagic/python3-puremagic.SlackBuild
@@ -0,0 +1,96 @@
+#!/bin/bash
+
+# Slackware build script for python3-puremagic
+
+# Copyright 2023 Steven Voges <Oregon, USA>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=python3-puremagic
+SRCNAM=puremagic
+VERSION=${VERSION:-1.15}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar -xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python3 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ *.rst CHANGELOG.md LICENSE PKG-INFO \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/python3-puremagic/python3-puremagic.info b/python/python3-puremagic/python3-puremagic.info
new file mode 100644
index 0000000000..cfcf5db642
--- /dev/null
+++ b/python/python3-puremagic/python3-puremagic.info
@@ -0,0 +1,10 @@
+PRGNAM="python3-puremagic"
+VERSION="1.15"
+HOMEPAGE="https://github.com/cdgriffith/puremagic"
+DOWNLOAD="https://files.pythonhosted.org/packages/50/bb/c9860ce714ce2147b6168fdf817e67c3be6eabc822fab5ef41cc52bafdec/puremagic-1.15.tar.gz"
+MD5SUM="421f523ec7be0c7cdb3cf600f6dfaae6"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Steven Voges"
+EMAIL="svoges.sbo@gmail.com"
diff --git a/python/python3-puremagic/slack-desc b/python/python3-puremagic/slack-desc
new file mode 100644
index 0000000000..8f9976fdda
--- /dev/null
+++ b/python/python3-puremagic/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python3-puremagic: python3-puremagic (Python file identification)
+python3-puremagic:
+python3-puremagic: Pure python implementation of identifying files based off their magic
+python3-puremagic: numbers
+python3-puremagic:
+python3-puremagic: Homepage: https://github.com/cdgriffith/puremagic
+python3-puremagic:
+python3-puremagic:
+python3-puremagic:
+python3-puremagic:
+python3-puremagic: