summaryrefslogtreecommitdiffstats
path: root/system/gkrellm-volume
diff options
context:
space:
mode:
author Eugen Wissner <belka@caraus.de>2021-04-17 09:51:55 +0200
committer Robby Workman <rworkman@slackbuilds.org>2021-04-17 23:24:33 -0500
commit994ad7e1e9378abd2b111030984e8720af032add (patch)
tree74dd2de0fbf0ca09907f419706a81a727d48d527 /system/gkrellm-volume
parent4e671be2b62017e6f78ef08bef1b3e38afadf23c (diff)
downloadslackbuilds-994ad7e1e9378abd2b111030984e8720af032add.tar.gz
slackbuilds-994ad7e1e9378abd2b111030984e8720af032add.tar.xz
system/gkrellm-volume: Removed (upstream disappeared).
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
Diffstat (limited to 'system/gkrellm-volume')
-rw-r--r--system/gkrellm-volume/Makefile.diff44
-rw-r--r--system/gkrellm-volume/README5
-rw-r--r--system/gkrellm-volume/gkrellm-volume.SlackBuild98
-rw-r--r--system/gkrellm-volume/gkrellm-volume.info10
-rw-r--r--system/gkrellm-volume/slack-desc19
5 files changed, 0 insertions, 176 deletions
diff --git a/system/gkrellm-volume/Makefile.diff b/system/gkrellm-volume/Makefile.diff
deleted file mode 100644
index 806ae79be3..0000000000
--- a/system/gkrellm-volume/Makefile.diff
+++ /dev/null
@@ -1,44 +0,0 @@
-diff -Nur gkrellm-volume.orig/Makefile gkrellm-volume/Makefile
---- gkrellm-volume.orig/Makefile 2004-08-19 15:07:27.000000000 -0500
-+++ gkrellm-volume/Makefile 2009-11-30 00:48:22.746711831 -0600
-@@ -14,7 +14,7 @@
- GTK_CFLAGS = `$(GTK_CONFIG) --cflags`
- GTK_LIB = `$(GTK_CONFIG) --libs`
-
--FLAGS = -O2 -Wall -fPIC $(GTK_CFLAGS) $(GKRELLM_INCLUDE)
-+FLAGS = -Wall -fPIC $(GTK_CFLAGS) $(GKRELLM_INCLUDE)
- LIBS = $(GTK_LIB)
- LFLAGS = -shared
-
-@@ -33,6 +33,7 @@
-
- CC = gcc $(CFLAGS) $(FLAGS)
-
-+MKDIR = mkdir -p
- INSTALL = install -c
- INSTALL_PROGRAM = $(INSTALL) -s
-
-@@ -48,7 +49,8 @@
-
- install:
- (cd po && ${MAKE} install)
-- $(INSTALL_PROGRAM) volume.so $(PLUGIN_DIR)
-+ $(MKDIR) $(DESTDIR)$(PLUGIN_DIR)
-+ $(INSTALL_PROGRAM) volume.so $(DESTDIR)/$(PLUGIN_DIR)
-
- %.c.o: %.c
-
-diff -Nur gkrellm-volume.orig/po/Makefile gkrellm-volume/po/Makefile
---- gkrellm-volume.orig/po/Makefile 2004-08-19 15:07:27.000000000 -0500
-+++ gkrellm-volume/po/Makefile 2009-11-30 00:47:52.124675094 -0600
-@@ -14,8 +14,8 @@
- install:
- $(MAKE) all
- for f in *.mo ; do mkdir -p \
-- $(INSTALL_PREFIX)$(LOCALEDIR)/`basename $$f .mo`/LC_MESSAGES ; \
-- cp $$f $(INSTALL_PREFIX)$(LOCALEDIR)/`basename $$f .mo`/LC_MESSAGES/$(PACKAGE).mo ; done
-+ $(DESTDIR)$(INSTALL_PREFIX)$(LOCALEDIR)/`basename $$f .mo`/LC_MESSAGES ; \
-+ cp $$f $(DESTDIR)$(INSTALL_PREFIX)$(LOCALEDIR)/`basename $$f .mo`/LC_MESSAGES/$(PACKAGE).mo ; done
-
- %.mo: %.po
- $(MSGFMT) -f -v -o $@ $<
diff --git a/system/gkrellm-volume/README b/system/gkrellm-volume/README
deleted file mode 100644
index 9f5fdc1cc0..0000000000
--- a/system/gkrellm-volume/README
+++ /dev/null
@@ -1,5 +0,0 @@
-gkrellm-volume is a plugin for gkrellm-2 that lets you control
-your sound mixer..
-
-This plugin also supports gkrellm's plugin theming possibilities;
-it's even included in the default gkrellm theme :).
diff --git a/system/gkrellm-volume/gkrellm-volume.SlackBuild b/system/gkrellm-volume/gkrellm-volume.SlackBuild
deleted file mode 100644
index 1114b5ae2c..0000000000
--- a/system/gkrellm-volume/gkrellm-volume.SlackBuild
+++ /dev/null
@@ -1,98 +0,0 @@
-#!/bin/sh
-
-### gkrellm-volume.SlackBuild ###
-
-# Slackware build script for gkrellm-volume 2.1.13
-# Copyright (C) 2006 paul wisehart wise@lupulin.net
-#
-# This program is free software; you can redistribute it and/or
-# modify it under the terms of the GNU General Public License
-# as published by the Free Software Foundation; either version 2
-# of the License, or (at your option) any later version.
-#
-# This program is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-# GNU General Public License for more details.
-
-# Modifed by the SlackBuilds.org project
-
-PRGNAM=gkrellm-volume
-VERSION=${VERSION:-2.1.13}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-# Patch the Makefile and po/Makefile to support DESTDIR
-patch -p1 < $CWD/Makefile.diff || exit 1
-
-make \
- CFLAGS="$SLKCFLAGS" \
- LOCALEDIR=/usr/share/locale \
- PLUGIN_DIR=/usr/lib${LIBDIRSUFFIX}/gkrellm2/plugins \
- GKRELLM_INCLUDE="-I/usr/include" \
- enable_nls=1 \
- enable_alsa=1
-
-make install \
- LOCALEDIR=/usr/share/locale \
- PLUGIN_DIR=/usr/lib${LIBDIRSUFFIX}/gkrellm2/plugins \
- GKRELLM_INCLUDE="-I/usr/include" \
- enable_nls=1 \
- enable_alsa=1 \
- DESTDIR=$PKG
-
-# Strip the .so file
-strip --strip-unneeded $PKG/usr/lib${LIBDIRSUFFIX}/gkrellm2/plugins/volume.so
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a COPYRIGHT Changelog README THEMING $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a po/README $PKG/usr/doc/$PRGNAM-$VERSION/README.po
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/system/gkrellm-volume/gkrellm-volume.info b/system/gkrellm-volume/gkrellm-volume.info
deleted file mode 100644
index a635147de8..0000000000
--- a/system/gkrellm-volume/gkrellm-volume.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="gkrellm-volume"
-VERSION="2.1.13"
-HOMEPAGE="http://gkrellm.luon.net/volume.php"
-DOWNLOAD="http://gkrellm.luon.net/files/gkrellm-volume-2.1.13.tar.gz"
-MD5SUM="d9f4c36d7fdf9c9f755c99f742b573c4"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Eugene Wissner"
-EMAIL="eugen@flevum.de"
diff --git a/system/gkrellm-volume/slack-desc b/system/gkrellm-volume/slack-desc
deleted file mode 100644
index 0783292cd4..0000000000
--- a/system/gkrellm-volume/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-gkrellm-volume: gkrellm-volume (gkrellm-volume plugin)
-gkrellm-volume:
-gkrellm-volume: A plugin which allows you to control the sound mixer devices
-gkrellm-volume: of your choice.
-gkrellm-volume:
-gkrellm-volume: Author: Sjoerd Simons <sjoerd@luon.net>
-gkrellm-volume:
-gkrellm-volume:
-gkrellm-volume:
-gkrellm-volume:
-gkrellm-volume: