summaryrefslogtreecommitdiffstats
path: root/system/graphite-web/patches
diff options
context:
space:
mode:
author Mario Preksavec <mario@slackware.hr>2016-07-24 19:18:50 +0200
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2016-07-30 08:28:21 +0700
commit7b3a2e146475aea46b550d4604bc95e7eb60020e (patch)
tree3f3af525fdb3c7b0ca4e0f08bc7e6e56ab3dfa6d /system/graphite-web/patches
parent1b52fb554491e387778920497ff55ed2b81af2be (diff)
downloadslackbuilds-7b3a2e146475aea46b550d4604bc95e7eb60020e.tar.gz
slackbuilds-7b3a2e146475aea46b550d4604bc95e7eb60020e.tar.xz
system/graphite-web: Updated for version 0.9.15.
Signed-off-by: Mario Preksavec <mario@slackware.hr>
Diffstat (limited to 'system/graphite-web/patches')
-rw-r--r--system/graphite-web/patches/graphite.wsgi.example.diff15
-rw-r--r--system/graphite-web/patches/setup.cfg.diff10
-rw-r--r--system/graphite-web/patches/setup.py.diff27
3 files changed, 25 insertions, 27 deletions
diff --git a/system/graphite-web/patches/graphite.wsgi.example.diff b/system/graphite-web/patches/graphite.wsgi.example.diff
index d4f436ae7a..2584cb7e7c 100644
--- a/system/graphite-web/patches/graphite.wsgi.example.diff
+++ b/system/graphite-web/patches/graphite.wsgi.example.diff
@@ -1,9 +1,10 @@
---- graphite-web-0.9.13-pre1/conf/graphite.wsgi.example.orig 2014-12-31 17:51:36.000000000 +0100
-+++ graphite-web-0.9.13-pre1/conf/graphite.wsgi.example 2015-02-19 18:26:43.753661979 +0100
-@@ -1,5 +1,5 @@
- import os, sys
+--- graphite-web-0.9.15/conf/graphite.wsgi.example.orig 2015-11-27 19:37:16.000000000 +0100
++++ graphite-web-0.9.15/conf/graphite.wsgi.example 2015-12-03 23:59:30.205576427 +0100
+@@ -1,6 +1,6 @@
+ import os
+ import sys
-sys.path.append('/opt/graphite/webapp')
-+sys.path.append('/usr/share/graphite/static')
- os.environ.setdefault('DJANGO_SETTINGS_MODULE', 'graphite.settings')
++sys.path.append('/usr/share/graphite-web/static')
- import django
+ try:
+ from importlib import import_module
diff --git a/system/graphite-web/patches/setup.cfg.diff b/system/graphite-web/patches/setup.cfg.diff
index f7ca20c9ba..cf244799f1 100644
--- a/system/graphite-web/patches/setup.cfg.diff
+++ b/system/graphite-web/patches/setup.cfg.diff
@@ -1,10 +1,6 @@
---- graphite-web-0.9.13-pre1/setup.cfg.orig 2014-12-31 17:51:36.000000000 +0100
-+++ graphite-web-0.9.13-pre1/setup.cfg 2015-02-19 16:45:23.526959108 +0100
-@@ -1,20 +0,0 @@
--[install]
--prefix = /opt/graphite
--install-lib = %(prefix)s/webapp
--
+--- graphite-web-0.9.15/setup.cfg.orig 2015-11-27 19:37:16.000000000 +0100
++++ graphite-web-0.9.15/setup.cfg 2015-12-04 00:24:12.045817187 +0100
+@@ -1,16 +0,0 @@
-[bdist_rpm]
-requires = Django => 1.1.4
- django-tagging
diff --git a/system/graphite-web/patches/setup.py.diff b/system/graphite-web/patches/setup.py.diff
index f300210bb8..64c9540e85 100644
--- a/system/graphite-web/patches/setup.py.diff
+++ b/system/graphite-web/patches/setup.py.diff
@@ -1,13 +1,14 @@
---- graphite-web-0.9.13-pre1/setup.py.orig 2014-12-31 17:51:36.000000000 +0100
-+++ graphite-web-0.9.13-pre1/setup.py 2015-02-19 18:45:25.173599991 +0100
-@@ -58,8 +58,7 @@
- 'graphite.thirdparty.pytz',
- ],
- package_data={'graphite' :
-- ['templates/*', 'local_settings.py.example']},
-- scripts=glob('bin/*'),
-- data_files=webapp_content.items() + storage_dirs + conf_files + examples,
-+ ['templates/*']},
-+ data_files=webapp_content.items() + conf_files,
- **setup_kwargs
- )
+--- graphite-web-0.9.15/setup.py.orig 2015-11-27 19:37:16.000000000 +0100
++++ graphite-web-0.9.15/setup.py 2015-12-04 02:50:48.311066851 +0100
+@@ -85,9 +85,8 @@
+ 'graphite.thirdparty.pytz',
+ ],
+ package_data={'graphite' :
+- ['templates/*', 'local_settings.py.example']},
+- scripts=glob('bin/*'),
+- data_files=webapp_content.items() + storage_dirs + conf_files + examples,
++ ['templates/*']},
++ data_files=webapp_content.items() + conf_files,
+ **setup_kwargs
+ )
+ finally: