summaryrefslogtreecommitdiffstats
path: root/system/nix/doinst.sh
diff options
context:
space:
mode:
author Pragmatic Cypher <slackbuilds@server.ky>2015-10-28 23:39:04 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2015-10-28 23:40:46 +0700
commit2848fce4b43fe4fb3b2d20d1cc38950724ded170 (patch)
treea38e9bfd04ee4b04f272c1aae4dbb2c38171f142 /system/nix/doinst.sh
parent85a7fa26ef1d63a0e803df775781f933810244c1 (diff)
downloadslackbuilds-2848fce4b43fe4fb3b2d20d1cc38950724ded170.tar.gz
slackbuilds-2848fce4b43fe4fb3b2d20d1cc38950724ded170.tar.xz
system/nix: Added (package manager).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'system/nix/doinst.sh')
-rw-r--r--system/nix/doinst.sh25
1 files changed, 25 insertions, 0 deletions
diff --git a/system/nix/doinst.sh b/system/nix/doinst.sh
new file mode 100644
index 0000000000..032197f9aa
--- /dev/null
+++ b/system/nix/doinst.sh
@@ -0,0 +1,25 @@
+config() {
+ NEW="$1"
+ OLD="$(dirname $NEW)/$(basename $NEW .new)"
+ # If there's no config file by that name, mv it over:
+ if [ ! -r $OLD ]; then
+ mv $NEW $OLD
+ elif [ "$(cat $OLD | md5sum)" = "$(cat $NEW | md5sum)" ]; then
+ # toss the redundant copy
+ rm $NEW
+ fi
+ # Otherwise, we leave the .new copy for the admin to consider...
+}
+
+preserve_perms() {
+ NEW="$1"
+ OLD="$(dirname $NEW)/$(basename $NEW .new)"
+ if [ -e $OLD ]; then
+ cp -a $OLD ${NEW}.incoming
+ cat $NEW > ${NEW}.incoming
+ mv ${NEW}.incoming $NEW
+ fi
+ config $NEW
+}
+
+preserve_perms etc/rc.d/rc.nix.new