summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--games/innoextract/README (renamed from system/innoextract/README)0
-rw-r--r--games/innoextract/innoextract.SlackBuild (renamed from system/innoextract/innoextract.SlackBuild)6
-rw-r--r--games/innoextract/innoextract.info (renamed from system/innoextract/innoextract.info)6
-rw-r--r--games/innoextract/slack-desc (renamed from system/innoextract/slack-desc)0
-rw-r--r--system/innoextract/innoextract-1.4-cmake-3.5.patch31
5 files changed, 4 insertions, 39 deletions
diff --git a/system/innoextract/README b/games/innoextract/README
index 7311965c9d..7311965c9d 100644
--- a/system/innoextract/README
+++ b/games/innoextract/README
diff --git a/system/innoextract/innoextract.SlackBuild b/games/innoextract/innoextract.SlackBuild
index 8674254c2f..d6dc13f328 100644
--- a/system/innoextract/innoextract.SlackBuild
+++ b/games/innoextract/innoextract.SlackBuild
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=innoextract
-VERSION=${VERSION:-1.5}
+VERSION=${VERSION:-1.6}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -69,10 +69,6 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-# Fix build with cmake-3.5
-# https://github.com/gentoo/gentoo/pull/1025
-patch -p1 < $CWD/innoextract-1.4-cmake-3.5.patch
-
mkdir -p build
cd build
cmake \
diff --git a/system/innoextract/innoextract.info b/games/innoextract/innoextract.info
index 7e7baf4ea5..be6644dabc 100644
--- a/system/innoextract/innoextract.info
+++ b/games/innoextract/innoextract.info
@@ -1,8 +1,8 @@
PRGNAM="innoextract"
-VERSION="1.5"
+VERSION="1.6"
HOMEPAGE="http://constexpr.org/innoextract/"
-DOWNLOAD="http://constexpr.org/innoextract/files/innoextract-1.5.tar.gz"
-MD5SUM="86dc2061e86df5ae8872cb7deacfcaf5"
+DOWNLOAD="http://constexpr.org/innoextract/files/innoextract-1.6.tar.gz"
+MD5SUM="17611d58ed51b8511639e5965c1585c5"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""
diff --git a/system/innoextract/slack-desc b/games/innoextract/slack-desc
index 37df8d9d1f..37df8d9d1f 100644
--- a/system/innoextract/slack-desc
+++ b/games/innoextract/slack-desc
diff --git a/system/innoextract/innoextract-1.4-cmake-3.5.patch b/system/innoextract/innoextract-1.4-cmake-3.5.patch
deleted file mode 100644
index 0b619ac381..0000000000
--- a/system/innoextract/innoextract-1.4-cmake-3.5.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-From 01705758dd04d937160c99c8b87c6fa2057db894 Mon Sep 17 00:00:00 2001
-From: Daniel Scharrer <daniel@constexpr.org>
-Date: Tue, 23 Feb 2016 05:45:50 +0100
-Subject: [PATCH] CMake: Disable variable expansion for quoted strings in if()
-
-This makes the build system more rubust against stray variables
-coming from included CMake scripts provided by the system.
-
-Fixes build with CMake 3.5 (tested with 3.5.0-rc3).
-
-Fixes: issue #50
----
- CMakeLists.txt | 5 +++++
- 1 file changed, 5 insertions(+)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 02e0308..8653b93 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -2,6 +2,11 @@ project(innoextract)
-
- cmake_minimum_required(VERSION 2.8)
-
-+if(POLICY CMP0054)
-+ # CMake 3.1+: Only interpret if() arguments as variables or keywords when unquoted.
-+ cmake_policy(SET CMP0054 NEW)
-+endif()
-+
-
- # Define configuration options
-