summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--system/spambayes/README6
-rw-r--r--system/spambayes/slack-desc11
-rw-r--r--system/spambayes/spambayes.SlackBuild43
-rw-r--r--system/spambayes/spambayes.info8
4 files changed, 68 insertions, 0 deletions
diff --git a/system/spambayes/README b/system/spambayes/README
new file mode 100644
index 0000000000..179ca058b7
--- /dev/null
+++ b/system/spambayes/README
@@ -0,0 +1,6 @@
+SpamBayes uses a different set of algorithm to most statistical spam filters,
+which enables to dramatically lower the number of legitimate mail classified as
+spam, through the introduction of an 'unsure' category.
+
+SpamBayes can be used as a POP3 or an IMAP proxy, as well as a simple mail
+filter for use with procmail.
diff --git a/system/spambayes/slack-desc b/system/spambayes/slack-desc
new file mode 100644
index 0000000000..19a9f0e3a3
--- /dev/null
+++ b/system/spambayes/slack-desc
@@ -0,0 +1,11 @@
+spambayes: spambayes (Python-based spam filter using statistical analysis)
+spambayes:
+spambayes: SpamBayes uses a different set of algorithm to most statistical spam
+spambayes: filters, which enables to dramatically lower the number of
+spambayes: legitimate mail classified as spam, through the introduction of an
+spambayes: 'unsure' category.
+spambayes:
+spambayes: SpamBayes can be used as a POP3 or an IMAP proxy, as well as a
+spambayes: simple mail filter for use with procmail.
+spambayes:
+spambayes: Homepage: http://spambayes.sourceforge.net/
diff --git a/system/spambayes/spambayes.SlackBuild b/system/spambayes/spambayes.SlackBuild
new file mode 100644
index 0000000000..687f6b9230
--- /dev/null
+++ b/system/spambayes/spambayes.SlackBuild
@@ -0,0 +1,43 @@
+#!/bin/sh
+
+# Slackware build script for spambayes
+
+# Copyright (c) 2007 Audrius Kažukauskas <neobug@tornado.ktu.lt>
+
+set -e
+
+PRGNAM=spambayes
+VERSION=1.0.4
+ARCH=noarch
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+CWD=`pwd`
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xzvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+
+chown -R root:root .
+chmod -R u+rw,go+r-w,a-s .
+
+python setup.py install --root=$PKG
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ CHANGELOG.txt LICENSE.txt NEWTRICKS.txt PKG-INFO POP3PROXY.txt \
+ README-DEVEL.txt README.txt TESTING.txt WHAT_IS_NEW.txt \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a contrib $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
diff --git a/system/spambayes/spambayes.info b/system/spambayes/spambayes.info
new file mode 100644
index 0000000000..3a386de675
--- /dev/null
+++ b/system/spambayes/spambayes.info
@@ -0,0 +1,8 @@
+PRGNAM="spambayes"
+VERSION="1.0.4"
+HOMEPAGE="http://spambayes.sourceforge.net/"
+DOWNLOAD="http://dl.sourceforge.net/spambayes/spambayes-1.0.4.tar.gz"
+MD5SUM="78c33e79888d410711ff3c7dd7e98d79"
+MAINTAINER="Audrius Kažukauskas"
+EMAIL="neobug@tornado.ktu.lt"
+APPROVED="Alan_Hicks"