summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--libraries/CEGUI/CEGUI.SlackBuild12
-rw-r--r--libraries/CEGUI/README7
2 files changed, 8 insertions, 11 deletions
diff --git a/libraries/CEGUI/CEGUI.SlackBuild b/libraries/CEGUI/CEGUI.SlackBuild
index 605546ce5c..a5f65c8feb 100644
--- a/libraries/CEGUI/CEGUI.SlackBuild
+++ b/libraries/CEGUI/CEGUI.SlackBuild
@@ -54,14 +54,14 @@ rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $SRCNAM-$VERSION
-tar xvf $CWD/$SRCNAM-$VERSION.tar.?z*
+tar xvf $CWD/$SRCNAM-$VERSION.tar.bz2
cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
+ -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ -exec chmod 644 {} \+
sed -i '1iadd_definitions(-std=c++11)' \
cegui/src/RendererModules/OpenGL/CMakeLists.txt \
@@ -83,14 +83,12 @@ cd build
-DCEGUI_BUILD_LUA_GENERATOR=OFF \
-DCEGUI_BUILD_LUA_GENERATOR=OFF \
-DCEGUI_BUILD_XMLPARSER_XERCES=OFF \
+ -DCEGUI_BUILD_RENDERER_OGRE=OFF \
-DCMAKE_BUILD_TYPE=Release ..
make
- make install DESTDIR=$PKG
+ make install/strip DESTDIR=$PKG
cd ..
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a doc *.txt $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
diff --git a/libraries/CEGUI/README b/libraries/CEGUI/README
index 27e98d5916..3e6e992552 100644
--- a/libraries/CEGUI/README
+++ b/libraries/CEGUI/README
@@ -14,8 +14,7 @@ particular, pay attention to the image codecs because you might want
to disable the others to ensure that the one you want to use is the
default codec.
-Optional dependencies include xerces-c, FreeImage, and DevIL.
-There are perhaps others - see the CMakeList.txt file
+Optional dependencies include glfw3, xerces-c, FreeImage, and DevIL.
+There are perhaps others - see the CMakeLists.txt file.
-*NOTE* ATM this won't build with ogre installed: you have to remove
-it explicitly from your system.
+The ogre renderer is disabled, as it won't build.