summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--system/maintboot/maintboot.SlackBuild10
-rw-r--r--system/maintboot/maintboot.info2
2 files changed, 3 insertions, 9 deletions
diff --git a/system/maintboot/maintboot.SlackBuild b/system/maintboot/maintboot.SlackBuild
index 00bbd020d4..1b33cbc765 100644
--- a/system/maintboot/maintboot.SlackBuild
+++ b/system/maintboot/maintboot.SlackBuild
@@ -38,9 +38,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -70,17 +67,14 @@ rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
-if [ -r $CWD/v$VERSION.tar.gz ]; then
- mv $CWD/v$VERSION.tar.gz $CWD/$PRGNAM-$VERSION.tar.gz
-fi
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} + -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} +
python3 setup.py install --root=$PKG
diff --git a/system/maintboot/maintboot.info b/system/maintboot/maintboot.info
index e32cf2cfc6..720ae104c5 100644
--- a/system/maintboot/maintboot.info
+++ b/system/maintboot/maintboot.info
@@ -1,7 +1,7 @@
PRGNAM="maintboot"
VERSION="0.1.0"
HOMEPAGE="https://github.com/g2p/maintboot"
-DOWNLOAD="https://github.com/g2p/maintboot/archive/v0.1.0.tar.gz"
+DOWNLOAD="https://github.com/g2p/maintboot/archive/v0.1.0/maintboot-0.1.0.tar.gz"
MD5SUM="6c58f3cd4cc944c22cb0c03054c132e6"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""