summaryrefslogtreecommitdiffstats
path: root/academic/sympy/sympy.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'academic/sympy/sympy.SlackBuild')
-rw-r--r--academic/sympy/sympy.SlackBuild12
1 files changed, 5 insertions, 7 deletions
diff --git a/academic/sympy/sympy.SlackBuild b/academic/sympy/sympy.SlackBuild
index e2d2ac6dd0..3f9688eb60 100644
--- a/academic/sympy/sympy.SlackBuild
+++ b/academic/sympy/sympy.SlackBuild
@@ -7,7 +7,7 @@
# Updated up to 0.7.5 by Serban Udrea <S.Udrea@gsi.de>
PRGNAM=sympy
-VERSION=${VERSION:-0.7.5}
+VERSION=${VERSION:-0.7.6}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -34,10 +34,10 @@ tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python setup.py install --root=$PKG
@@ -47,9 +47,7 @@ find $PKG/usr/man -type f -exec gzip -9 {} \;
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- AUTHORS LICENSE PKG-INFO README.rst \
- $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS LICENSE PKG-INFO README.rst $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install