summaryrefslogtreecommitdiffstats
path: root/desktop/lxde-common/lxde-common.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'desktop/lxde-common/lxde-common.SlackBuild')
-rw-r--r--desktop/lxde-common/lxde-common.SlackBuild31
1 files changed, 14 insertions, 17 deletions
diff --git a/desktop/lxde-common/lxde-common.SlackBuild b/desktop/lxde-common/lxde-common.SlackBuild
index 2cf9ba96f8..62e9f73e27 100644
--- a/desktop/lxde-common/lxde-common.SlackBuild
+++ b/desktop/lxde-common/lxde-common.SlackBuild
@@ -37,6 +37,8 @@
# 0.5.0-1: 13/sep/2010 by ponce <matteo.bernardini@gmail.com>
# * Adapted to slackbuilds.org's autotools template.
# * fixed lxpanel and xinitrc
+# 20110313_736ded3: 29/mar/2011 by ponce <matteo.bernardini@gmail.com>
+# * updated to git version.
#
# Run 'sh lxde-common.SlackBuild' to build a Slackware package.
# The package is created in /tmp .
@@ -45,21 +47,19 @@
# -----------------------------------------------------------------------------
PRGNAM=lxde-common
-VERSION=${VERSION:-0.5.0}
-BUILD=${BUILD:-3}
+VERSION=${VERSION:-20110313_736ded3}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
-# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i486 ;;
arm*) ARCH=arm ;;
- # Unless $ARCH is already set, use uname -m for all other archs:
*) ARCH=$( uname -m ) ;;
esac
fi
-DOCS="AUTHORS COPYING ChangeLog NEWS README"
+DOCS="AUTHORS COPYING INSTALL ChangeLog NEWS README"
CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
@@ -96,9 +96,14 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-# patch panel config to use slackware applications and slightly modify default config
+# Patch panel config to use slackware applications and slightly modify default config
patch -p1 < $CWD/config/panel.patch
+# Look for a renamed file
+sed -i -e 's|lxde\.conf|LXDE.conf|' Makefile.am
+
+sh autogen.sh
+
CXXFLAGS="$SLKCFLAGS" \
CFLAGS="$SLKCFLAGS" \
./configure \
@@ -116,7 +121,7 @@ make
make DESTDIR=$PKG install
mkdir -p $PKG/usr/share/applications
-cp lxde-logout.desktop $PKG/usr/share/applications
+cp lxde-logout.desktop $PKG/usr/share/applications/
# Add a xinitrc file for xwmconfig:
mkdir -p $PKG/etc/X11/xinit
@@ -129,20 +134,12 @@ mkdir -p $PKG/usr/share/apps/kdm/sessions
for i in $(ls ../../../xsessions/*.desktop) ; do ln -sf $i ; done
)
-# patch desktop.conf for Tango icon theme
+# Patch desktop.conf to use the Tango icon theme
sed -i -e 's#nuoveXT2#Tango#' $PKG/etc/xdg/lxsession/LXDE/desktop.conf
-# patch autostart for the new pcmanfm
-sed -i -e 's#pcmanfm#pcmanfm --desktop#' $PKG/etc/xdg/lxsession/LXDE/autostart
-
-# set a default config for pcmanfm
-mkdir -p $PKG/etc/xdg/pcmanfm
-cp $CWD/config/default-pcmanfm.conf $PKG/etc/xdg/pcmanfm/pcmanfm.conf
-cp $CWD/config/default-main.lxde $PKG/etc/xdg/pcmanfm/main.lxde
-
# Add documentation:
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION || true
+cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
chown -R root:root $PKG/usr/doc/$PRGNAM-$VERSION
find $PKG/usr/doc -type f -exec chmod 644 {} \;