summaryrefslogtreecommitdiffstats
path: root/desktop/quickswitch-i3/quickswitch-i3.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'desktop/quickswitch-i3/quickswitch-i3.SlackBuild')
-rw-r--r--desktop/quickswitch-i3/quickswitch-i3.SlackBuild14
1 files changed, 6 insertions, 8 deletions
diff --git a/desktop/quickswitch-i3/quickswitch-i3.SlackBuild b/desktop/quickswitch-i3/quickswitch-i3.SlackBuild
index e3d10129fd..5b6d5c69a0 100644
--- a/desktop/quickswitch-i3/quickswitch-i3.SlackBuild
+++ b/desktop/quickswitch-i3/quickswitch-i3.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for quickswitch-i3
-# Copyright 2014-2016 Dimitris Zlatanidis Orestiada, Greece
+# Copyright 2014-2017 Dimitris Zlatanidis Orestiada, Greece
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,7 +23,8 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=quickswitch-i3
-VERSION=${VERSION:-2.1}
+SRCNAM=quickswitch-for-i3
+VERSION=${VERSION:-2.6.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -59,9 +60,9 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz || tar xvf $CWD/$VERSION.tar.gz
+cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
@@ -69,9 +70,6 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-# fix i3-py error message for slackbuilds.org users
-patch -p1 < $CWD/13_py_message.patch
-
python setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \