summaryrefslogtreecommitdiffstats
path: root/desktop/wmmon/wmmon.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'desktop/wmmon/wmmon.SlackBuild')
-rw-r--r--desktop/wmmon/wmmon.SlackBuild84
1 files changed, 84 insertions, 0 deletions
diff --git a/desktop/wmmon/wmmon.SlackBuild b/desktop/wmmon/wmmon.SlackBuild
new file mode 100644
index 0000000000..f5027c54c2
--- /dev/null
+++ b/desktop/wmmon/wmmon.SlackBuild
@@ -0,0 +1,84 @@
+#!/bin/sh
+
+# Slackware build script for wmmon
+
+# Written by B. Watson (yalhcru@gmail.com)
+
+PRGNAM=wmmon
+VERSION=1.0b2_p14
+ARCH=${ARCH:-i486}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+SRCVER=$(echo $VERSION | cut -d_ -f1)
+PATCHVER=$(echo $VERSION | cut -d_ -f2)
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIR=-L/usr/lib
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIR=-L/usr/lib
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIR=-L/usr/lib64
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM.app
+tar xvf $CWD/$PRGNAM-$SRCVER.tar.gz
+cd $PRGNAM.app
+chown -R root:root .
+chmod -R a-s,u+w,go+r-w .
+
+# wmmon was pretty much abandoned by the original developer 10+ years ago.
+# The Debian maintainer has added some security-related fixes, a man page,
+# better support for 2.6 kernels, and some extra features. Most people
+# would prefer to run the patched version...
+patch -p1 < $CWD/patches/${PRGNAM}_$SRCVER-$PATCHVER.diff
+
+# This patch is necessary because the $#!%^#$^ wmmonrc file parser doesn't
+# fully support comments: they are allowed, but a commented-out (but
+# otherwise valid) config directive is still processed as though it
+# weren't commented out! Ack!
+patch -p1 < $CWD/patches/rc_file_parser.diff
+
+# The man page refers to "the clock" (probably copied from wmclock docs),
+# change to "the window".
+patch -p1 < $CWD/patches/manpage_window_not_clock.diff
+
+cd $PRGNAM
+ sed -i -e "s/-O2/$SLKCFLAGS/" Makefile
+ make LIBDIR="$LIBDIR"
+ strip $PRGNAM
+ mkdir -p $PKG/usr/bin
+ install -m0755 -o root -g root $PRGNAM $PKG/usr/bin
+ mkdir -p $PKG/usr/man/man1
+ gzip -9c $PRGNAM.1 > $PKG/usr/man/man1/$PRGNAM.1.gz
+cd -
+
+mkdir -p $PKG/etc
+cat $CWD/wmmonrc > $PKG/etc/wmmonrc.sample
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ BUGS CHANGES COPYING HINTS INSTALL README TODO \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a debian/changelog $PKG/usr/doc/$PRGNAM-$VERSION/changelog.debian
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz