summaryrefslogtreecommitdiffstats
path: root/development/icon/icon.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'development/icon/icon.SlackBuild')
-rw-r--r--development/icon/icon.SlackBuild15
1 files changed, 2 insertions, 13 deletions
diff --git a/development/icon/icon.SlackBuild b/development/icon/icon.SlackBuild
index 5f11d22f27..ec7a9611b7 100644
--- a/development/icon/icon.SlackBuild
+++ b/development/icon/icon.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for icon
-# Copyright 2010-2021 Kyle Guinn <elyk03@gmail.com>
+# Copyright 2010-2022 Kyle Guinn <elyk03@gmail.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,7 +25,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=icon
-VERSION=${VERSION:-9.5.20i}
+VERSION=${VERSION:-9.5.22e}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -38,9 +38,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -80,14 +77,6 @@ cd $PRGNAM-$VERSION
chown -R root:root .
chmod -R u+w,go-w,a+rX-st .
-# Use the system XPM. https://github.com/gtownsend/icon/pull/2
-sed -i -e 's|"../xpm/xpm.h"|<X11/xpm.h>|' src/common/xwindow.c src/h/sys.h
-# Neuter the $XL variable, replace with $XLIBS which includes -lXpm.
-# Set $XLIBS to empty if building without graphics (make Configure).
-sed -i -e 's|-lX11|-lXpm -lX11|' config/linux/Makedefs
-sed -i -e 's|XL=.*|XL= ;;|' config/setup.sh
-sed -i -e 's|XL|XLIBS|' src/runtime/Makefile
-
# Installation creates bin, lib, man, and doc dirs inside the "dest" dir.
# Edit the Install rule to avoid having to manually rearrange files.
# The bin and lib dirs need to share a parent directory, but we don't want