summaryrefslogtreecommitdiffstats
path: root/development/protobuf3/protobuf3.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'development/protobuf3/protobuf3.SlackBuild')
-rw-r--r--development/protobuf3/protobuf3.SlackBuild22
1 files changed, 10 insertions, 12 deletions
diff --git a/development/protobuf3/protobuf3.SlackBuild b/development/protobuf3/protobuf3.SlackBuild
index 6d7c993407..83a5c11db3 100644
--- a/development/protobuf3/protobuf3.SlackBuild
+++ b/development/protobuf3/protobuf3.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for protobuf3
-# Copyright 2017-2022 Willy Sudiarto Raharjo <willysr@slackbuilds.org>
+# Copyright 2017-2024 Willy Sudiarto Raharjo <willysr@slackbuilds.org>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,7 +25,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=protobuf3
-VERSION=${VERSION:-25.3}
+VERSION=${VERSION:-26.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -81,10 +81,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-patch -p1 < $CWD/protobuf3.patch
-patch -p1 < $CWD/protobuf-21.12-pep517.patch
patch -p1 < $CWD/soversion.patch
-sed -e "s|c++14|c++17|" -i python/setup.py
mkdir -p build
cd build
@@ -101,13 +98,14 @@ cd build
make install/strip DESTDIR=$PKG
cd ..
-# Install the python bindings
-cd python
-LDFLAGS+=" -L$TMP/$SRCNAM-$VERSION/build" \
-PROTOC="$TMP/$SRCNAM-$VERSION/build/protoc" \
-python3 -m build --wheel --no-isolation
-python3 -m installer --destdir "$PKG" dist/*.whl
-cd ..
+# Install the python bindings:
+#cd python
+#cp -a dist/setup.py .
+#LDFLAGS+=" -L$TMP/$SRCNAM-$VERSION/build" \
+#PROTOC="$TMP/$SRCNAM-$VERSION/build/protoc" \
+#python3 -m build --wheel --no-isolation
+#python3 -m installer --destdir "$PKG" dist/*.whl
+#cd ..
rm -rf $PKG/usr/lib${LIBDIRSUFFIX}/*.la