summaryrefslogtreecommitdiffstats
path: root/games/bsnes/bsnes.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'games/bsnes/bsnes.SlackBuild')
-rw-r--r--games/bsnes/bsnes.SlackBuild33
1 files changed, 23 insertions, 10 deletions
diff --git a/games/bsnes/bsnes.SlackBuild b/games/bsnes/bsnes.SlackBuild
index db126d5e86..187a0b584c 100644
--- a/games/bsnes/bsnes.SlackBuild
+++ b/games/bsnes/bsnes.SlackBuild
@@ -5,7 +5,7 @@
# Written by Larry Hajali <larryhaja[at]gmail[dot]com>
PRGNAM=bsnes
-VERSION=${VERSION:-0.068}
+VERSION=${VERSION:-0.072}
SRCVER=${VERSION:2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -57,7 +57,7 @@ find . \
cd $PRGNAM
# Patch makefile so SLKCFLAGS and LIBDIRSUFFIX are recognized.
-cat $CWD/bsnes-0.068-makefile.patch \
+cat $CWD/bsnes-0.072-makefile.patch \
| sed -e "/^\+/s|/lib/|/lib${LIBDIRSUFFIX}/|g" \
| patch -p1
@@ -66,15 +66,27 @@ cat $CWD/bsnes-0.068-makefile.patch \
sed -i \
-e 's|audio.pulseaudio ||' \
-e 's|audio.pulseaudiosimple ||' \
- -e '/pulse/d' qt/Makefile
+ -e '/pulse/d' ui-qt/Makefile
-CXXFLAGS="$SLKCFLAGS" \
-make \
- platform=x \
- compiler=gcc \
- prefix=/usr
+for profile in compatibility performance accuracy; do
+ CXXFLAGS="$SLKCFLAGS" \
+ make \
+ platform=x \
+ compiler=gcc \
+ prefix=/usr \
+ ui=ui-qt \
+ profile=$profile
+
+ make install DESTDIR=$PKG prefix=/usr profile=$profile
+ make clean
+done
-make install DESTDIR=$PKG prefix=/usr
+# Install the launcher
+cd launcher
+sed -i -e '/^clear/d' -e "s|-O3|$SLKCFLAGS|" cc.sh
+./cc.sh
+install -m 0755 ../out/bsnes $PKG/usr/bin/bsnes
+cd ..
# Install plugins.
for i in snesfilter snesreader supergameboy; do
@@ -86,6 +98,7 @@ for i in snesfilter snesreader supergameboy; do
prefix=/usr
make install DESTDIR=$PKG prefix=/usr
+ ( cd $PKG/usr/lib${LIBDIRSUFFIX} ; ln -s lib${i}.so lib${i}.so.1 )
cd -
done
@@ -93,7 +106,7 @@ find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a qt/data/*.html $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a ui-qt/data/*.html $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
find $PKG/usr/doc -type f -exec chmod 0644 {} \;