summaryrefslogtreecommitdiffstats
path: root/games/cgmadness/01-Makefile.patch
diff options
context:
space:
mode:
Diffstat (limited to 'games/cgmadness/01-Makefile.patch')
-rw-r--r--games/cgmadness/01-Makefile.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/games/cgmadness/01-Makefile.patch b/games/cgmadness/01-Makefile.patch
new file mode 100644
index 0000000000..731f081481
--- /dev/null
+++ b/games/cgmadness/01-Makefile.patch
@@ -0,0 +1,30 @@
+diff -Nur cgmadness/Makefile cgmadness.new/Makefile
+--- cgmadness/Makefile 2011-09-09 19:55:46.000000000 +0200
++++ cgmadness.new/Makefile 2012-10-30 23:36:52.000000000 +0100
+@@ -18,7 +18,7 @@
+ CPREFIX :=
+
+ CC := $(CPREFIX)gcc
+-CFLAGS := -Wall -Werror
++CFLAGS := -Wall
+
+ CXX := $(CPREFIX)g++
+ CXXFLAGS = $(CFLAGS) -pedantic -I.
+@@ -53,7 +53,7 @@
+ LIBS_NETWORK += -lpthreadGCE2 -lwsock32 -lws2_32
+ EXECSUFFIX := .exe
+ endif
+-ifneq ($(findstring linux-gnu,$(MACHINE)),)
++ifneq ($(findstring slackware-linux,$(MACHINE)),)
+ CXXFLAGS += -ansi
+ LIBS_OPENGL += -lglut -lGLEW
+ LIBS_NETWORK += -lpthread
+@@ -115,7 +115,7 @@
+
+ %$(EXECSUFFIX): $(BUILD)/%.o
+ @echo " LINK $@"
+- @$(LD) $(LDFLAGS) $^ $(foreach find, $(FIND_LIBS), $(call $(find),$^)) -o $@
++ @$(LD) $(LDFLAGS) $^ $(foreach find, $(FIND_LIBS), $(call $(find),$^)) -o $@ -lGL -lGLU
+
+ $(BUILD)/%.o: %.c | $$(@D)/.
+ @echo " CC $@"