summaryrefslogtreecommitdiffstats
path: root/games/jzintv/jzintv.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'games/jzintv/jzintv.SlackBuild')
-rw-r--r--games/jzintv/jzintv.SlackBuild19
1 files changed, 7 insertions, 12 deletions
diff --git a/games/jzintv/jzintv.SlackBuild b/games/jzintv/jzintv.SlackBuild
index a02683fc21..7512c21163 100644
--- a/games/jzintv/jzintv.SlackBuild
+++ b/games/jzintv/jzintv.SlackBuild
@@ -5,7 +5,7 @@
# Written by B. Watson (yalhcru@gmail.com)
PRGNAM=jzintv
-VERSION=${VERSION:-1.0_beta3}
+VERSION=${VERSION:-r1007}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -24,8 +24,6 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-SRCVER=$(echo $VERSION | sed 's/_/-/')
-
if [ "$ARCH" = "i486" ]; then
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
LIBDIRSUFFIX=""
@@ -45,22 +43,19 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM-$SRCVER
-unzip $CWD/$PRGNAM-$SRCVER-src.zip
-cd $PRGNAM-$SRCVER
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.?z*
+cd $PRGNAM-$VERSION
chown -R root:root .
chmod -R a-s,u+w,go+r-w .
-# jzintv defines a dprintf macro that clashes with stdio.h
-# when -D_GNU_SOURCE=1 (and sdl-config --cflags defines that,
-# not jzintv's Makefile). The patch changes the jzintv version
-# to jzintv_dprintf.
-patch -p1 < $CWD/jzintv_dprintf.patch
-
# Don't see a way to redefine the ROM path on the make command
# line (it's hard-coded to /usr/local/share/jzintv/rom).
patch -p1 < $CWD/jzintv_rompath.patch
+# Fix for gcc-4.7.x
+sed -i "s|L\.\./lib|L../lib -lm|" src/Makefile
+
cd src
make OPT_FLAGS="$SLKCFLAGS"
cd -