summaryrefslogtreecommitdiffstats
path: root/games/megaglest/megaglest-help2man.patch
diff options
context:
space:
mode:
Diffstat (limited to 'games/megaglest/megaglest-help2man.patch')
-rw-r--r--games/megaglest/megaglest-help2man.patch12
1 files changed, 12 insertions, 0 deletions
diff --git a/games/megaglest/megaglest-help2man.patch b/games/megaglest/megaglest-help2man.patch
new file mode 100644
index 0000000000..77a312f0b6
--- /dev/null
+++ b/games/megaglest/megaglest-help2man.patch
@@ -0,0 +1,12 @@
+diff -up megaglest-3.12.0/source/g3d_viewer/CMakeLists.txt.orig megaglest-3.12.0/source/g3d_viewer/CMakeLists.txt
+--- megaglest-3.12.0/source/g3d_viewer/CMakeLists.txt.orig 2016-06-24 07:36:58.912496205 -0300
++++ megaglest-3.12.0/source/g3d_viewer/CMakeLists.txt 2016-06-24 07:37:24.409497821 -0300
+@@ -174,7 +174,7 @@ IF(BUILD_MEGAGLEST_MODEL_VIEWER)
+ MESSAGE(STATUS "***-- Found xvfb-run: ${XVFB_EXEC} about to build manpage with it.")
+
+ add_custom_target(${TARGET_NAME_MANPAGE} ALL
+- COMMAND ${XVFB_EXEC} --auto-servernum --server-num=770 ${HELP2MAN} --no-discard-stderr --name='${MG_MANPAGE_DESCRIPTION}' --section=6 -N -o ${HELP2MAN_OUT_PATH}${TARGET_NAME_MANPAGE} ${HELP2MAN_OUT_PATH}${TARGET_NAME}
++ COMMAND ${XVFB_EXEC} --auto-servernum ${HELP2MAN} --name='${MG_MANPAGE_DESCRIPTION}' --section=6 -N -o ${HELP2MAN_OUT_PATH}${TARGET_NAME_MANPAGE} ${HELP2MAN_OUT_PATH}${TARGET_NAME}
+ DEPENDS ${TARGET_NAME})
+ ELSE()
+ add_custom_target(${TARGET_NAME_MANPAGE} ALL