summaryrefslogtreecommitdiffstats
path: root/games/megaglest/megaglest.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'games/megaglest/megaglest.SlackBuild')
-rw-r--r--games/megaglest/megaglest.SlackBuild17
1 files changed, 7 insertions, 10 deletions
diff --git a/games/megaglest/megaglest.SlackBuild b/games/megaglest/megaglest.SlackBuild
index 4e58f2f3b6..81668613e7 100644
--- a/games/megaglest/megaglest.SlackBuild
+++ b/games/megaglest/megaglest.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for megaglest
-# Copyright 2011-2013 Larry Hajali <larryhaj[at]gmail[dot]com>
+# Copyright 2011-2015 Larry Hajali <larryhaj[at]gmail[dot]com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=megaglest
-VERSION=${VERSION:-3.9.1}
+VERSION=${VERSION:-3.11.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -67,20 +67,17 @@ cd $PRGNAM-$VERSION
find . -type l -exec rm -f '{}' \;
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
# Fix megaglest help2man when no X display is available. Use a wrapper
-# script from upstream for Xvfb that creates a temporary *fake* framebuffer
+# script from upstream for Xvfb that creates a temporary *fake* framebuffer.
install -D -m 0755 $CWD/xvfb-run $TMP/$SRCDIR/bin/xvfb-run
export PATH="$PATH:$TMP/$SRCDIR/bin"
patch -p1 < $CWD/megaglest-3.9.0-help2man.patch
-# Fix file location in CMakeLists.txt
-sed -i 's|data/glest_game/||' source/glest_game/CMakeLists.txt
-
mkdir build
cd build
cmake -G "Unix Makefiles" \