summaryrefslogtreecommitdiffstats
path: root/games/nethack/patches/Makefile_utl.patch
diff options
context:
space:
mode:
Diffstat (limited to 'games/nethack/patches/Makefile_utl.patch')
-rw-r--r--games/nethack/patches/Makefile_utl.patch51
1 files changed, 51 insertions, 0 deletions
diff --git a/games/nethack/patches/Makefile_utl.patch b/games/nethack/patches/Makefile_utl.patch
new file mode 100644
index 0000000000..6a5c4d34cd
--- /dev/null
+++ b/games/nethack/patches/Makefile_utl.patch
@@ -0,0 +1,51 @@
+--- sys/unix/Makefile.utl 2003-12-07 17:39:13.000000000 -0600
++++ sys/unix/Makefile.utl.slack 2008-05-15 15:29:29.000000000 -0500
+@@ -15,7 +15,7 @@
+
+ # if you are using gcc as your compiler,
+ # uncomment the CC definition below if it's not in your environment
+-# CC = gcc
++CC = gcc
+ #
+ # For Bull DPX/2 systems at B.O.S. 2.0 or higher use the following:
+ #
+@@ -73,7 +73,7 @@
+ # flags for Linux
+ # compile normally
+ # CFLAGS = -O2 -fomit-frame-pointer -I../include
+-# LFLAGS = -L/usr/X11R6/lib
++LFLAGS = -L/usr/lib
+ # OR compile backwards compatible a.out format
+ # CFLAGS = -O2 -b i486-linuxaout -fomit-frame-pointer -I../include
+ # LFLAGS = -b i486-linuxaout -L/usr/X11R6/lib
+@@ -90,7 +90,7 @@
+ # CFLAGS = -g -I../include
+
+ CFLAGS = -O -I../include
+-LFLAGS =
++# LFLAGS =
+
+ LIBS =
+
+@@ -101,11 +101,11 @@
+
+ # yacc/lex programs to use to generate *_comp.h, *_lex.c, and *_yacc.c.
+ # if, instead of yacc/lex you have bison/flex, comment/uncomment the following.
+-YACC = yacc
+-LEX = lex
+-# YACC = bison -y
++# YACC = yacc
++# LEX = lex
++YACC = bison -y
+ # YACC = byacc
+-# LEX = flex
++LEX = flex
+
+ # these are the names of the output files from YACC/LEX. Under MS-DOS
+ # and similar systems, they may differ
+@@ -400,4 +400,4 @@
+
+ tileedit: tileedit.cpp $(TEXT_IO)
+ $(QTDIR)/bin/moc -o tileedit.moc tileedit.h
+- $(CC) -o tileedit -I../include -I$(QTDIR)/include -L$(QTDIR)/lib tileedit.cpp $(TEXT_IO) -lqt
++ $(CC) -o tileedit -I../include -I$(QTDIR)/include -L$(QTDIR)/lib tileedit.cpp $(TEXT_IO) -lqt-mt