summaryrefslogtreecommitdiffstats
path: root/games/sdlpop/sdlpop.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'games/sdlpop/sdlpop.SlackBuild')
-rw-r--r--games/sdlpop/sdlpop.SlackBuild28
1 files changed, 20 insertions, 8 deletions
diff --git a/games/sdlpop/sdlpop.SlackBuild b/games/sdlpop/sdlpop.SlackBuild
index 71e9b00a3e..f24ccdcb4f 100644
--- a/games/sdlpop/sdlpop.SlackBuild
+++ b/games/sdlpop/sdlpop.SlackBuild
@@ -6,8 +6,16 @@
# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
+# 20170316 bkw:
+# - updated for v1.17.
+# - use github for download (saves bandwidth, the homepage's zip file has
+# windows exes and dlls in it).
+# - don't include README.md (it just says 'see Readme.txt').
+# - update man page (new 1.17 options).
+# - update wrapper script to support both system-wide and per-user mods.
+
PRGNAM=sdlpop
-VERSION=${VERSION:-1.16}
+VERSION=${VERSION:-1.17}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -46,7 +54,7 @@ rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $ZIPNAME-$VERSION
-unzip -a $CWD/$ZIPNAME-$VERSION.zip -x '*.dll' '*.exe' $ZIPNAME-$VERSION/prince
+unzip -a $CWD/$ZIPNAME-$VERSION.zip
cd $ZIPNAME-$VERSION
chown -R root:root .
find -L . \
@@ -55,29 +63,33 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-sed -i "/^CFLAGS/s,\$, $SLKCFLAGS," Makefile
-make
+sed -i "/^CFLAGS/s,\$, $SLKCFLAGS," src/Makefile
+make -C src
mkdir -p $PKG/usr/libexec/$PRGNAM $PKG/usr/games
install -s -m0755 prince $PKG/usr/libexec/$PRGNAM
install -m0755 $CWD/$PRGNAM.sh $PKG/usr/games/$PRGNAM
mkdir -p $PKG/usr/share/games/$PRGNAM
-cp -a *.ini *.DAT data $PKG/usr/share/games/$PRGNAM
+cp -a *.ini data mods $PKG/usr/share/games/$PRGNAM
# man page written for this build
mkdir -p $PKG/usr/man/man6
gzip -9c < $CWD/$PRGNAM.6 > $PKG/usr/man/man6/$PRGNAM.6.gz
+mkdir -p $PKG/usr/share/applications $PKG/usr/share/pixmaps
+
# icon downloaded from:
# http://www.veryicon.com/icons/game/mega-games-pack-26/prince-persia-2008-2.html
-# .desktop written for this build
-mkdir -p $PKG/usr/share/applications $PKG/usr/share/pixmaps
+# 1.17 now has an icon.png, but it's 32x32 and not transparent, so I'll keep
+# using the one I used for 1.16.
cat $CWD/$PRGNAM.png > $PKG/usr/share/pixmaps/$PRGNAM.png
+
+# .desktop written for this build
cat $CWD/$PRGNAM.desktop > $PKG/usr/share/applications/$PRGNAM.desktop
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a README.md doc/* $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a doc/* $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install