summaryrefslogtreecommitdiffstats
path: root/gis/python3-shapely/python3-shapely.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'gis/python3-shapely/python3-shapely.SlackBuild')
-rw-r--r--gis/python3-shapely/python3-shapely.SlackBuild8
1 files changed, 3 insertions, 5 deletions
diff --git a/gis/python3-shapely/python3-shapely.SlackBuild b/gis/python3-shapely/python3-shapely.SlackBuild
index 32b62acf2f..e6507cb0eb 100644
--- a/gis/python3-shapely/python3-shapely.SlackBuild
+++ b/gis/python3-shapely/python3-shapely.SlackBuild
@@ -26,7 +26,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-shapely
-VERSION=${VERSION:-2.0.1}
+VERSION=${VERSION:-2.0.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -63,10 +63,8 @@ tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -perm /111 -o \! -perm 755 -o -exec chmod 755 {} + -a \
+ \! -perm /111 -o \! -perm 644 -o -exec chmod 644 {} +
# Fixing numpy dependency check in pyproject.toml:
# oldest-supported-numpy has a strict check and doesn't support newer version