summaryrefslogtreecommitdiffstats
path: root/graphics/HotShots/HotShots.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/HotShots/HotShots.SlackBuild')
-rw-r--r--graphics/HotShots/HotShots.SlackBuild47
1 files changed, 10 insertions, 37 deletions
diff --git a/graphics/HotShots/HotShots.SlackBuild b/graphics/HotShots/HotShots.SlackBuild
index a05b1a87a5..811c6ec68d 100644
--- a/graphics/HotShots/HotShots.SlackBuild
+++ b/graphics/HotShots/HotShots.SlackBuild
@@ -2,28 +2,10 @@
# Slackware build script for HotShots
-# Copyright 2013 Andrey Maraev <andrew.maraev60@yandex.ru>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# Written by Andrey Maraev <andrew.maraev60@yandex.ru>
PRGNAM=HotShots
-VERSION=${VERSION:-1.2.1}
+VERSION=${VERSION:-2.0.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -59,28 +41,19 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM-$VERSION
-unzip $CWD/$PRGNAM-$VERSION.zip
-cd $PRGNAM-$VERSION
+rm -rf $PRGNAM-$VERSION-src
+unzip $CWD/$PRGNAM-$VERSION-src.zip
+cd $PRGNAM-$VERSION-src
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-# Fix translations path
-cd $TMP/$PRGNAM-$VERSION/src
-sed -i "s!/usr/local/share/locale!/usr/share/hotshots/lang!g" MiscFunctions.cpp
-sed -i "s!/usr/share/local/locale!/usr/share/hotshots/lang!g" MiscFunctions.cpp
-cd $TMP/$PRGNAM-$VERSION/build
-sed -i "s!share/locale!share/hotshots/lang!g" CMakeLists.txt
-
-# Fix libqxt include path
-sed -i "s!/usr/include/qxt/!/usr/include/!g" CMakeLists.txt
+ cd $TMP/$PRGNAM-$VERSION-src/build
cmake \
- -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
-DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_BUILD_TYPE=Release .