summaryrefslogtreecommitdiffstats
path: root/graphics/dia/dia.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/dia/dia.SlackBuild')
-rw-r--r--graphics/dia/dia.SlackBuild18
1 files changed, 17 insertions, 1 deletions
diff --git a/graphics/dia/dia.SlackBuild b/graphics/dia/dia.SlackBuild
index 3eacc8ad4d..a3dd7b330c 100644
--- a/graphics/dia/dia.SlackBuild
+++ b/graphics/dia/dia.SlackBuild
@@ -5,11 +5,19 @@
# Originally written by Matt Hayes <dominian at slackadelic dot com>
# Updated for 64bit by Ash Wiren <ash at spooksoftware dot com> (19.08.2009)
# Maintained by Dugan Chen <thedoogster at gmail dot com> (<= 18.09.2015)
+#
# Updated and currently maintained by Philip Lacroix <slackph at posteo dot de>
+#
+# 19.09.2015:
+# - reviewed and updated for dia 0.97.3.
+# 10.10.2015:
+# - enabled HTML documentation (based on patch by Mike Gorse, SUSE);
+# - enabled python and cairo plug-ins, SWIG;
+# - disabled gnome code (deprecated).
PRGNAM=dia
VERSION=${VERSION:-0.97.3}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -55,6 +63,9 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+# Enable HTML documentation, necessary for online help functionality.
+patch configure.in < $CWD/dia-enable-html-docs.patch
+
autoreconf -fi
CFLAGS="$SLKCFLAGS" \
@@ -64,6 +75,11 @@ CXXFLAGS="$SLKCFLAGS" \
--mandir=/usr/man \
--libdir=/usr/lib${LIBDIRSUFFIX} \
--docdir=/usr/doc/$PRGNAM-$VERSION \
+ --with-swig \
+ --with-cairo \
+ --with-python \
+ --disable-gnome \
+ --disable-static \
--build=$ARCH-slackware-linux
make