summaryrefslogtreecommitdiffstats
path: root/libraries/RxCpp/RxCpp.patch
diff options
context:
space:
mode:
Diffstat (limited to 'libraries/RxCpp/RxCpp.patch')
-rw-r--r--libraries/RxCpp/RxCpp.patch40
1 files changed, 40 insertions, 0 deletions
diff --git a/libraries/RxCpp/RxCpp.patch b/libraries/RxCpp/RxCpp.patch
new file mode 100644
index 0000000000..239f607b24
--- /dev/null
+++ b/libraries/RxCpp/RxCpp.patch
@@ -0,0 +1,40 @@
+diff -ur RxCpp-3.0.0.old/projects/CMake/CMakeLists.txt RxCpp-3.0.0/projects/CMake/CMakeLists.txt
+--- RxCpp-3.0.0.old/projects/CMake/CMakeLists.txt 2016-11-25 17:51:43.000000000 -0200
++++ RxCpp-3.0.0/projects/CMake/CMakeLists.txt 2017-01-06 14:25:44.185727167 -0200
+@@ -11,18 +11,18 @@
+
+ MESSAGE( STATUS "RXCPP_DIR: " ${RXCPP_DIR} )
+
+-add_subdirectory(${RXCPP_DIR}/Rx/v2/test ${CMAKE_CURRENT_BINARY_DIR}/test)
++#add_subdirectory(${RXCPP_DIR}/Rx/v2/test ${CMAKE_CURRENT_BINARY_DIR}/test)
+
+ add_subdirectory(${RXCPP_DIR}/projects/doxygen ${CMAKE_CURRENT_BINARY_DIR}/projects/doxygen)
+
+-set(EXAMPLES_DIR ${RXCPP_DIR}/Rx/v2/examples)
++#set(EXAMPLES_DIR ${RXCPP_DIR}/Rx/v2/examples)
+
+-add_subdirectory(${EXAMPLES_DIR}/cep ${CMAKE_CURRENT_BINARY_DIR}/examples/cep)
+-add_subdirectory(${EXAMPLES_DIR}/stop ${CMAKE_CURRENT_BINARY_DIR}/examples/stop)
+-add_subdirectory(${EXAMPLES_DIR}/linesfrombytes ${CMAKE_CURRENT_BINARY_DIR}/examples/linesfrombytes)
+-add_subdirectory(${EXAMPLES_DIR}/println ${CMAKE_CURRENT_BINARY_DIR}/examples/println)
+-add_subdirectory(${EXAMPLES_DIR}/pythagorian ${CMAKE_CURRENT_BINARY_DIR}/examples/pythagorian)
+-add_subdirectory(${EXAMPLES_DIR}/tests ${CMAKE_CURRENT_BINARY_DIR}/examples/tests)
++#add_subdirectory(${EXAMPLES_DIR}/cep ${CMAKE_CURRENT_BINARY_DIR}/examples/cep)
++#add_subdirectory(${EXAMPLES_DIR}/stop ${CMAKE_CURRENT_BINARY_DIR}/examples/stop)
++#add_subdirectory(${EXAMPLES_DIR}/linesfrombytes ${CMAKE_CURRENT_BINARY_DIR}/examples/linesfrombytes)
++#add_subdirectory(${EXAMPLES_DIR}/println ${CMAKE_CURRENT_BINARY_DIR}/examples/println)
++#add_subdirectory(${EXAMPLES_DIR}/pythagorian ${CMAKE_CURRENT_BINARY_DIR}/examples/pythagorian)
++#add_subdirectory(${EXAMPLES_DIR}/tests ${CMAKE_CURRENT_BINARY_DIR}/examples/tests)
+
+ # The list of RxCpp source files. Please add every new file to this list
+ set(RX_SOURCES
+@@ -131,5 +131,6 @@
+
+ set(CMAKE_SKIP_INSTALL_ALL_DEPENDENCY TRUE CACHE BOOL "Don't require all projects to be built in order to install" FORCE)
+
+-install(DIRECTORY ${RXCPP_DIR}/Rx/v2/src/rxcpp/ DESTINATION rxcpp
+- FILES_MATCHING PATTERN "*.hpp")
+\ No newline at end of file
++install(DIRECTORY ${RXCPP_DIR}/Rx/v2/src/rxcpp/ DESTINATION include/rxcpp
++ FILES_MATCHING PATTERN "*.hpp")
++install(TARGETS RxCpp DESTINATION lib${LIB_SUFFIX})