summaryrefslogtreecommitdiffstats
path: root/libraries/aubio/aubio.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'libraries/aubio/aubio.SlackBuild')
-rw-r--r--libraries/aubio/aubio.SlackBuild31
1 files changed, 23 insertions, 8 deletions
diff --git a/libraries/aubio/aubio.SlackBuild b/libraries/aubio/aubio.SlackBuild
index f034b00b67..48e8c876be 100644
--- a/libraries/aubio/aubio.SlackBuild
+++ b/libraries/aubio/aubio.SlackBuild
@@ -23,11 +23,16 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# 20230722 bkw: BUILD=2
+# - fix conflict with Sphinx.
+# - add prebuilt man pages (to avoid depending on txt2man, which isn't even
+# in the SBo repo yet).
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=aubio
VERSION=${VERSION:-0.4.9}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -39,9 +44,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -76,9 +78,9 @@ cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} + -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} +
# Fix detecting ffmpeg
sed -i "s|'HAVE_' + i in ctx.env.define_key|'HAVE_' + i in ctx.env|" \
@@ -87,6 +89,13 @@ sed -i "s|'HAVE_' + i in ctx.env.define_key|'HAVE_' + i in ctx.env|" \
# Fix the build system...
sed -i "s|'\${DATAROOTDIR}' + '/doc/libaubio-doc|'\${DOCDIR}|" wscript || exit 1
+# 20230722 bkw: if Sphinx is missing, the build is OK. if it's
+# installed, it gets audodetected, then the build fails later. Could
+# fix with --disable-docs, but that also disables the rest of the
+# docs. Also, since I've added prebuilt man pages, disable the man
+# page generation.
+sed -i -e '/^ *sphinx(bld)/d' -e '/^ *txt2man(bld)/d' wscript
+
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./waf configure \
@@ -107,8 +116,8 @@ cd ..
cp -a $PRGNAM-$VERSION $PRGNAM-$VERSION-2
cd -
-if $(python -c 'import numpy' 2>/dev/null); then
- python setup.py install --root=$PKG
+if $(python2 -c 'import numpy' 2>/dev/null); then
+ python2 setup.py install --root=$PKG
fi
if $(python3 -c 'import numpy' 2>/dev/null); then
( cd ../$PRGNAM-$VERSION-2
@@ -118,6 +127,12 @@ fi
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+# 20230722 bkw: prebuilt man pages.
+mkdir -p $PKG/usr/man/man1
+for i in $CWD/man/*; do
+ gzip -9c < $i > $PKG/usr/man/man1/$( basename $i ).gz
+done
+
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a AUTHORS ChangeLog COPYING README.md VERSION \
$PKG/usr/doc/$PRGNAM-$VERSION