summaryrefslogtreecommitdiffstats
path: root/misc/zyGrib/zyGrib.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'misc/zyGrib/zyGrib.SlackBuild')
-rw-r--r--misc/zyGrib/zyGrib.SlackBuild11
1 files changed, 6 insertions, 5 deletions
diff --git a/misc/zyGrib/zyGrib.SlackBuild b/misc/zyGrib/zyGrib.SlackBuild
index 2aa37f0c97..73c217845d 100644
--- a/misc/zyGrib/zyGrib.SlackBuild
+++ b/misc/zyGrib/zyGrib.SlackBuild
@@ -3,6 +3,7 @@
# Slackware build script for zyGrib
# Copyright 2011, 2012, 2013 Chris Abela, Malta
+# Copyright 2014 Ryan P.C. McQuen, WA, ryan.q@linux.com
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,7 +24,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=zyGrib
-VERSION=${VERSION:-6.1.4}
+VERSION=${VERSION:-6.2.3}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -68,10 +69,10 @@ tar xvf $CWD/$SRCTAR
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
# Makefile installs a good local installation, but we need a system installation
patch -p0 < $CWD/Makefile.patch