summaryrefslogtreecommitdiffstats
path: root/multimedia/kaffeine/kaffeine.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'multimedia/kaffeine/kaffeine.SlackBuild')
-rw-r--r--multimedia/kaffeine/kaffeine.SlackBuild17
1 files changed, 8 insertions, 9 deletions
diff --git a/multimedia/kaffeine/kaffeine.SlackBuild b/multimedia/kaffeine/kaffeine.SlackBuild
index b2705152b5..3bb4a2f908 100644
--- a/multimedia/kaffeine/kaffeine.SlackBuild
+++ b/multimedia/kaffeine/kaffeine.SlackBuild
@@ -23,8 +23,8 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=kaffeine
-VERSION=${VERSION:-1.2.2}
-BUILD=${BUILD:-2}
+VERSION=${VERSION:-1.3.1}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -66,13 +66,12 @@ tar xvf $CWD/$PRGNAM-$SRC_VERSION.tar.gz
cd $PRGNAM-$SRC_VERSION
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-# Add upstream patch
-patch -p1 < $CWD/kaffeine-fix-gcc4.7.patch
+patch -p1 < $CWD/CMakeLists.patch
mkdir -p build
cd build
cmake \
@@ -87,7 +86,7 @@ cd build
make install VERBOSE=1 DESTDIR=$PKG
cd -
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION