summaryrefslogtreecommitdiffstats
path: root/network/fail2ban/fail2ban.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'network/fail2ban/fail2ban.SlackBuild')
-rw-r--r--network/fail2ban/fail2ban.SlackBuild18
1 files changed, 13 insertions, 5 deletions
diff --git a/network/fail2ban/fail2ban.SlackBuild b/network/fail2ban/fail2ban.SlackBuild
index 964fae5803..e210f7d712 100644
--- a/network/fail2ban/fail2ban.SlackBuild
+++ b/network/fail2ban/fail2ban.SlackBuild
@@ -3,7 +3,7 @@
# Slackware Package Build Script for fail2ban
# Git Hub: https://github.com/fail2ban/fail2ban/
-# Copyright (c) 2008-2013, Nishant Limbachia, Hoffman Estates, IL, USA
+# Copyright (c) 2008-2014, Nishant Limbachia, Hoffman Estates, IL, USA
# <nishant _AT_ mnspace _DOT_ net>
# All rights reserved.
@@ -26,7 +26,7 @@
# SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM="fail2ban"
-VERSION=${VERSION:-0.8.11}
+VERSION=${VERSION:-0.9.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -49,7 +49,9 @@ find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
-o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+( cd fail2ban/client; patch -p0 < $CWD/patches/fail2banreader-logwarning-fix.patch )
python setup.py install --root=$PKG
@@ -66,17 +68,23 @@ install -m 0644 man/jail.conf.5 $PKG/usr/man/man5
done
)
+( cd $PKG/etc/fail2ban; patch -p0 < $CWD/patches/jail.conf.patch )
+
find $PKG/usr/man -type f -exec gzip -9 {} \;
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
# install startup script
install -D -m 0644 $CWD/rc.fail2ban $PKG/etc/rc.d/rc.fail2ban.new
+install -D -m 0644 $CWD/config/paths-slackware.conf $PKG/etc/fail2ban/paths-slackware.conf.new
+
+# remove non-slackware specific stuff
+rm -f $PKG/etc/fail2ban/paths-{debian,fedora,freebsd,osx}.conf.new
# install logrotate script
install -D -m 0644 $CWD/fail2ban.logrotate $PKG/etc/logrotate.d/fail2ban.new
-# make directory for socket and pid file
-mkdir -p $PKG/var/run/fail2ban
+# make directory for socket, pid file & db file
+mkdir -p $PKG/var/{run,lib}/fail2ban
# remove /usr/share/doc
rm -fr $PKG/usr/share/doc