summaryrefslogtreecommitdiffstats
path: root/network/graphite-carbon/graphite-carbon.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'network/graphite-carbon/graphite-carbon.SlackBuild')
-rw-r--r--network/graphite-carbon/graphite-carbon.SlackBuild134
1 files changed, 134 insertions, 0 deletions
diff --git a/network/graphite-carbon/graphite-carbon.SlackBuild b/network/graphite-carbon/graphite-carbon.SlackBuild
new file mode 100644
index 0000000000..ecf248df23
--- /dev/null
+++ b/network/graphite-carbon/graphite-carbon.SlackBuild
@@ -0,0 +1,134 @@
+#!/bin/sh
+
+# Slackware build script for carbon
+
+# Copyright 2015 Mario Preksavec, Zagreb, HR
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=graphite-carbon
+SRCNAM=carbon
+SRCVER=0.9.13-pre1
+VERSION=${VERSION:-0.9.13pre1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+# Bail if user or group isn't valid on your system
+if ! grep ^graphite: /etc/passwd 2>&1 > /dev/null; then
+
+cat << EOF
+
+ You must have graphite user and a group to run this script
+
+ # groupadd -g 299 graphite
+ # useradd -u 299 -d /var/lib/graphite -s /bin/false -g graphite graphite
+
+EOF
+
+ exit
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$SRCVER
+tar xvf $CWD/$SRCVER.tar.gz
+cd $SRCNAM-$SRCVER
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+# Set some sane defaults
+patch -p1 <$CWD/patches/carbon.conf.example.diff
+# We don't have a RedHat system
+patch -p1 <$CWD/patches/setup.cfg.diff
+# Look for config file in /etc/carbon
+patch -p1 <$CWD/patches/validate-storage-schemas.py.diff
+
+python setup.py install --root=$PKG
+
+# Need some dirs
+mkdir -p $PKG/etc/{rc.d,logrotate.d} $PKG/var/{lib/graphite/whisper,log/carbon}
+chown -R graphite:graphite $PKG/var/lib/graphite $PKG/var/log/carbon
+
+# Install rc script
+install -D -m0644 -oroot -groot $CWD/rc.carbon-cache \
+ $PKG/etc/rc.d/rc.carbon-cache.new
+
+# Logrotate script
+install -D -m0644 -oroot -groot $CWD/graphite-carbon.logrotate \
+ $PKG/etc/logrotate.d/graphite-carbon.new
+
+# Configuration goes into /etc/carbon
+mv $PKG/usr/conf $PKG/etc/carbon
+for i in $PKG/etc/carbon/*.example ; do mv $i ${i/.example/.new} ; done
+
+# Do we really want .py suffix in /usr/bin
+for i in $PKG/usr/bin/*.py ; do mv $i ${i/.py/} ; done
+
+# Cruft removal
+rm -rf $PKG/usr/storage
+
+# Manpages thanks to Debian folks!
+mkdir -p $PKG/usr/man
+cp -a $CWD/man1 $PKG/usr/man
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}