summaryrefslogtreecommitdiffstats
path: root/python/Pyro4/Pyro4.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/Pyro4/Pyro4.SlackBuild')
-rw-r--r--python/Pyro4/Pyro4.SlackBuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/python/Pyro4/Pyro4.SlackBuild b/python/Pyro4/Pyro4.SlackBuild
index 7e701a6408..ec8f7f56d8 100644
--- a/python/Pyro4/Pyro4.SlackBuild
+++ b/python/Pyro4/Pyro4.SlackBuild
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=Pyro4
-VERSION=${VERSION:-4.20}
+VERSION=${VERSION:-4.22}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -64,19 +64,19 @@ tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python setup.py install --root=$PKG
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a LICENSE README.txt docs/ examples/ $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}