summaryrefslogtreecommitdiffstats
path: root/python/cssutils/cssutils.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/cssutils/cssutils.SlackBuild')
-rw-r--r--python/cssutils/cssutils.SlackBuild12
1 files changed, 10 insertions, 2 deletions
diff --git a/python/cssutils/cssutils.SlackBuild b/python/cssutils/cssutils.SlackBuild
index 5ab326326c..6f87b9b307 100644
--- a/python/cssutils/cssutils.SlackBuild
+++ b/python/cssutils/cssutils.SlackBuild
@@ -23,8 +23,8 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=cssutils
-VERSION=${VERSION:-0.9.10}
-BUILD=${BUILD:-2}
+VERSION=${VERSION:-1.0}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
CWD=$(pwd)
@@ -60,8 +60,16 @@ for FILE in $(find . -type f -exec grep -Pl '\r$' {} \;); do
sed -i 's/\r//g' $FILE
done
+# Don't use ez_setup. Use system setuptools or fail.
+sed -i '/ez_setup/d' setup.py
+
python setup.py install --root=$PKG
+if $(python3 -c 'import setuptools' 2>/dev/null); then
+ rm -rf build
+ python3 setup.py install --root=$PKG
+fi
+
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true