summaryrefslogtreecommitdiffstats
path: root/python/psutil/psutil.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/psutil/psutil.SlackBuild')
-rw-r--r--python/psutil/psutil.SlackBuild19
1 files changed, 13 insertions, 6 deletions
diff --git a/python/psutil/psutil.SlackBuild b/python/psutil/psutil.SlackBuild
index 7503837b6e..aafbc3d9b1 100644
--- a/python/psutil/psutil.SlackBuild
+++ b/python/psutil/psutil.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for psutil
-# Copyright 2012-2015 Larry Hajali <larryhaja[at]gmail[dot]com>
+# Copyright 2012-2016 Larry Hajali <larryhaja[at]gmail[dot]com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=psutil
-VERSION=${VERSION:-3.3.0}
+VERSION=${VERSION:-4.3.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -45,9 +45,9 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
+rm -rf $PRGNAM-release-$VERSION
+tar xvf $CWD/$PRGNAM-release-$VERSION.tar.gz
+cd $PRGNAM-release-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
@@ -55,6 +55,13 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+# Remove shebangs
+find psutil -name "*\.py" | while read line; do
+ sed -i.orig '/^#!/d' $line
+ touch -r ${line}.orig $line
+ rm ${line}.orig
+done
+
python setup.py install --root=$PKG
# Install python3 bindings for psutil. Default is no.
@@ -66,7 +73,7 @@ find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | gr
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a CREDITS LICENSE TODO *.rst $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a CREDITS IDEAS LICENSE *.rst $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install