summaryrefslogtreecommitdiffstats
path: root/python/python-sh/python-sh.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/python-sh/python-sh.SlackBuild')
-rw-r--r--python/python-sh/python-sh.SlackBuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/python/python-sh/python-sh.SlackBuild b/python/python-sh/python-sh.SlackBuild
index 61c0b9ff78..bc53982e33 100644
--- a/python/python-sh/python-sh.SlackBuild
+++ b/python/python-sh/python-sh.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for python-sh
-# Copyright 2012-2015 Larry Hajali <larryhaja[at]gmail[dot]com>
+# Copyright 2012-2016 Larry Hajali <larryhaja[at]gmail[dot]com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,13 +23,13 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=python-sh
-VERSION=${VERSION:-1.11}
+VERSION=${VERSION:-1.12.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -57,7 +57,7 @@ find -L . \
python setup.py install --root=$PKG
-if $(python3 -c 'import os' 2>/dev/null); then
+if [ "${PYTHON3:-no}" == "yes" ]; then
python3 setup.py install --root=$PKG
fi
@@ -65,7 +65,7 @@ find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | gr
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a AUTHORS.md LICENSE.txt PKG-INFO README.md $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE.txt *.md $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install