summaryrefslogtreecommitdiffstats
path: root/system/glances/glances.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'system/glances/glances.SlackBuild')
-rw-r--r--system/glances/glances.SlackBuild27
1 files changed, 12 insertions, 15 deletions
diff --git a/system/glances/glances.SlackBuild b/system/glances/glances.SlackBuild
index b584404c41..6e5959dc48 100644
--- a/system/glances/glances.SlackBuild
+++ b/system/glances/glances.SlackBuild
@@ -23,8 +23,8 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=glances
-VERSION=${VERSION:-2.3}
-BUILD=${BUILD:-2}
+VERSION=${VERSION:-2.4.1}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -47,8 +47,8 @@ mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
-# The upstream tarball will be named differently, depending on the file
-# being downloaded manually (web browser) or with wget.
+# The upstream tarball will be named differently, depending on
+# the file being downloaded manually (web browser) or with wget.
if [ -e $CWD/v$VERSION.tar.gz ]; then
tar xvzf $CWD/v$VERSION.tar.gz
else
@@ -63,11 +63,6 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 \
-o -perm 400 \) -exec chmod 644 {} \;
-PRGUSR=$PKG/usr
-PRGSHR=$PKG/usr/share
-PRGETC=$PKG/etc/$PRGNAM
-PRGDOC=$PKG/usr/doc/$PRGNAM-$VERSION
-
python setup.py install --root=$PKG
# Python 3 support.
@@ -79,20 +74,22 @@ find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" \
| grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null \
|| true
-# Don't mess with existing config files.
-mv $PRGETC/$PRGNAM.conf $PRGETC/$PRGNAM.conf.new
+PRGUSR=$PKG/usr
+PRGSHR=$PKG/usr/share
+PRGDOC=$PKG/usr/doc/$PRGNAM-$VERSION
-mv $PRGSHR/man $PKG/usr/
-gzip -9 $PRGUSR/man/man?/*.?
+# Compress man page.
+mv $PRGSHR/man $PRGUSR/
+gzip -9 $PRGUSR/man/man1/$PRGNAM.1
+# Install documentation.
mkdir -p $PRGDOC
mv $PRGSHR/doc/$PRGNAM/* $PRGDOC/
-rm -rf $PRGSHR
cat $CWD/$PRGNAM.SlackBuild > $PRGDOC/$PRGNAM.SlackBuild
+rm -rf $PRGSHR
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
-cat $CWD/doinst.sh > $PKG/install/doinst.sh
cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}