summaryrefslogtreecommitdiffstats
path: root/system/linuxconsoletools/linuxconsoletools.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'system/linuxconsoletools/linuxconsoletools.SlackBuild')
-rw-r--r--system/linuxconsoletools/linuxconsoletools.SlackBuild17
1 files changed, 10 insertions, 7 deletions
diff --git a/system/linuxconsoletools/linuxconsoletools.SlackBuild b/system/linuxconsoletools/linuxconsoletools.SlackBuild
index ef30234847..f968883ac9 100644
--- a/system/linuxconsoletools/linuxconsoletools.SlackBuild
+++ b/system/linuxconsoletools/linuxconsoletools.SlackBuild
@@ -22,8 +22,11 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# 20140315 bkw: took over maintenance, updated for 1.4.7, replaced patch
+# with a bit of sed.
+
PRGNAM=linuxconsoletools
-VERSION=${VERSION:-1.4.4}
+VERSION=${VERSION:-1.4.7}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -64,13 +67,13 @@ tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-# Patch to install manpages in /usr/man instead of /usr/share/man
-patch -p1 < $CWD/$PRGNAM-$VERSION.patch
+# install manpages in /usr/man instead of /usr/share/man
+sed -i 's,share/man,man,g' docs/Makefile
# No ./configure provided
make CFLAGS="$SLKCFLAGS" PREFIX=/usr