summaryrefslogtreecommitdiffstats
path: root/system/qemu-kvm/fixup-undefined-pci-references.patch
diff options
context:
space:
mode:
Diffstat (limited to 'system/qemu-kvm/fixup-undefined-pci-references.patch')
-rw-r--r--system/qemu-kvm/fixup-undefined-pci-references.patch51
1 files changed, 0 insertions, 51 deletions
diff --git a/system/qemu-kvm/fixup-undefined-pci-references.patch b/system/qemu-kvm/fixup-undefined-pci-references.patch
deleted file mode 100644
index 4a002c7bf2..0000000000
--- a/system/qemu-kvm/fixup-undefined-pci-references.patch
+++ /dev/null
@@ -1,51 +0,0 @@
-Replace obsolete qemu-kvm.h with kvm.h in pci.c and build that module
-just like upstream does. This fixes non-x86 targets which have no PCI
-support.
-
-Signed-off-by: Jan Kiszka <jan.kiszka@xxxxxxxxxxx>
----
- Makefile.objs | 2 +-
- Makefile.target | 2 +-
- hw/pci.c | 2 +-
- 3 files changed, 3 insertions(+), 3 deletions(-)
-
-diff --git a/Makefile.objs b/Makefile.objs
-index f5702eb..3ec7121 100644
---- a/Makefile.objs
-+++ b/Makefile.objs
-@@ -170,7 +170,7 @@ hw-obj-y =
- hw-obj-y += loader.o
- hw-obj-$(CONFIG_VIRTIO) += virtio.o virtio-console.o
- hw-obj-y += fw_cfg.o
--hw-obj-$(CONFIG_PCI) += pci_bridge.o
-+hw-obj-$(CONFIG_PCI) += pci.o pci_bridge.o
- hw-obj-$(CONFIG_PCI) += msix.o msi.o
- hw-obj-$(CONFIG_PCI) += pci_host.o pcie_host.o
- hw-obj-$(CONFIG_PCI) += ioh3420.o xio3130_upstream.o xio3130_downstream.o
-diff --git a/Makefile.target b/Makefile.target
-index 6e9a024..23367eb 100644
---- a/Makefile.target
-+++ b/Makefile.target
-@@ -195,7 +195,7 @@ endif #CONFIG_BSD_USER
- # System emulator target
- ifdef CONFIG_SOFTMMU
-
--obj-y = arch_init.o cpus.o monitor.o pci.o machine.o gdbstub.o vl.o balloon.o
-+obj-y = arch_init.o cpus.o monitor.o machine.o gdbstub.o vl.o balloon.o
- # virtio has to be here due to weird dependency between PCI and virtio-net.
- # need to fix this properly
- obj-$(CONFIG_NO_PCI) += pci-stub.o
-diff --git a/hw/pci.c b/hw/pci.c
-index 0c44939..1f6cebe 100644
---- a/hw/pci.c
-+++ b/hw/pci.c
-@@ -29,8 +29,8 @@
- #include "net.h"
- #include "sysemu.h"
- #include "loader.h"
--#include "qemu-kvm.h"
- #include "hw/pc.h"
-+#include "kvm.h"
- #include "device-assignment.h"
- #include "qemu-objects.h"
- #include "range.h"