summaryrefslogtreecommitdiffstats
path: root/system/virtualbox-kernel/virtualbox-kernel.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'system/virtualbox-kernel/virtualbox-kernel.SlackBuild')
-rw-r--r--system/virtualbox-kernel/virtualbox-kernel.SlackBuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/system/virtualbox-kernel/virtualbox-kernel.SlackBuild b/system/virtualbox-kernel/virtualbox-kernel.SlackBuild
index 4986c9e36f..0f73f1d7fb 100644
--- a/system/virtualbox-kernel/virtualbox-kernel.SlackBuild
+++ b/system/virtualbox-kernel/virtualbox-kernel.SlackBuild
@@ -25,7 +25,7 @@
# Modified by SlackBuilds.org
PRGNAM=virtualbox-kernel
-VERSION=${VERSION:-4.0.4}
+VERSION=${VERSION:-4.0.8}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -61,6 +61,11 @@ cd $PRGNAM-$VERSION
chown -R root:root .
chmod -R u+w,go+r-w,a-s .
+if ! [ "${HARDENING:-yes}" = "yes" ]; then
+ sed -i "s/ -DVBOX_WITH_HARDENING//g" \
+ {vboxdrv,vboxnetadp,vboxnetflt}/Makefile
+fi
+
make KERN_DIR=${KERNELPATH}
mkdir -p $PKG/lib/modules/$KERNEL/misc