summaryrefslogtreecommitdiffstats
path: root/source/d/llvm/llvm.SlackBuild
diff options
context:
space:
mode:
author Patrick J Volkerding <volkerdi@slackware.com>2024-03-07 20:40:08 +0000
committer Eric Hameleers <alien@slackware.com>2024-03-07 22:49:08 +0100
commit66e838eb2b90374a91406df2f10d14bd6d528f38 (patch)
tree25c41b4a07b80c70ffc1fc20d7dd609f4972877a /source/d/llvm/llvm.SlackBuild
parentc3fb4577bf0ad3f9a7369ba6b4d9be979de8fc9f (diff)
downloadcurrent-66e838eb2b90374a91406df2f10d14bd6d528f38.tar.gz
current-66e838eb2b90374a91406df2f10d14bd6d528f38.tar.xz
Thu Mar 7 20:40:08 UTC 202420240307204008
ap/ghostscript-10.03.0-x86_64-1.txz: Upgraded. This update addresses a security issue: A vulnerability was identified in the way Ghostscript/GhostPDL called tesseract for the OCR devices, which could allow arbitrary code execution. Thanks to J_W for the heads-up. (* Security fix *) ap/lxc-4.0.12-x86_64-3.txz: Rebuilt. lxc-slackware.in: include gnupg2 (not gnupg) for slackpkg. ap/slackpkg-15.0.10-noarch-3.txz: Rebuilt. core-functions.sh: use gpg2, not gpg. d/Cython-3.0.9-x86_64-1.txz: Upgraded. d/git-2.44.0-x86_64-2.txz: Rebuilt. Include git-subtree. Thanks to gwhl. d/llvm-18.1.0-x86_64-1.txz: Upgraded. Shared library .so-version bump. kde/kdevelop-23.08.5-x86_64-2.txz: Rebuilt. Recompiled against llvm-18.1.0. l/openexr-3.2.3-x86_64-1.txz: Upgraded. l/python-importlib_metadata-7.0.2-x86_64-1.txz: Upgraded. l/python-trove-classifiers-2024.3.3-x86_64-1.txz: Upgraded. l/qt5-5.15.12_20240228_6609503f-x86_64-1.txz: Upgraded. Compiled against llvm-18.1.0. l/qt6-6.6.2_20240210_15b7e743-x86_64-3.txz: Rebuilt. Recompiled against llvm-18.1.0. l/spirv-llvm-translator-18.1.0-x86_64-1.txz: Upgraded. Shared library .so-version bump. n/gnupg2-2.4.5-x86_64-1.txz: Upgraded. n/libassuan-2.5.7-x86_64-1.txz: Upgraded. n/postfix-3.9.0-x86_64-1.txz: Upgraded. x/mesa-24.0.2-x86_64-2.txz: Rebuilt. Recompiled against llvm-18.1.0 and spirv-llvm-translator-18.1.0. isolinux/initrd.img: Rebuilt. Fixed kernel version. Thanks to chrisVV. usb-and-pxe-installers/usbboot.img: Rebuilt. Fixed kernel version. Thanks to chrisVV.
Diffstat (limited to 'source/d/llvm/llvm.SlackBuild')
-rwxr-xr-xsource/d/llvm/llvm.SlackBuild34
1 files changed, 17 insertions, 17 deletions
diff --git a/source/d/llvm/llvm.SlackBuild b/source/d/llvm/llvm.SlackBuild
index f285bf332..5ed30e9d1 100755
--- a/source/d/llvm/llvm.SlackBuild
+++ b/source/d/llvm/llvm.SlackBuild
@@ -3,7 +3,7 @@
# Slackware build script for llvm
# Copyright 2008-2016 Heinz Wiesinger, Amsterdam, The Netherlands
-# Copyright 2012, 2013, 2014, 2015, 2016, 2018, 2019, 2020, 2021, 2022, 2023 Patrick J. Volkerding, Sebeka, MN, USA
+# Copyright 2012, 2013, 2014, 2015, 2016, 2018, 2019, 2020, 2021, 2022, 2023, 2024 Patrick J. Volkerding, Sebeka, MN, USA
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -99,13 +99,6 @@ PY2=$(python -c 'from distutils.sysconfig import get_python_lib; print(get_pytho
# Python3 short version:
PY3=$(python3 -c 'from distutils.sysconfig import get_python_lib; print(get_python_lib())' | cut -f 2 -d n | cut -f 1 -d /)
-# Sadly, glibc-2.30 exposed some sort of problem with clang and icecream.
-# The symptom is a compile failure that says none of the types in
-# <linux/types.h> are defined, even though they are. gcc/g++ seem unaffected.
-# For now, not much choice other than to disable this.
-# Don't use icecream:
-#PATH=$(echo $PATH | sed "s|/usr/libexec/icecc/bin||g" | tr -s : | sed "s/^://g" | sed "s/:$//g")
-
rm -rf $PKG $BUILDDIR
mkdir -p $TMP $PKG $BUILDDIR
cd $BUILDDIR
@@ -123,6 +116,10 @@ mv cmake-$VERSION.src cmake
echo "Extracting $CWD/third-party-$VERSION.src.tar.xz..."
tar xf $CWD/third-party-$VERSION.src.tar.xz || exit 1
mv third-party-$VERSION.src third-party
+echo "Extracting $CWD/runtimes-$VERSION.src.tar.xz..."
+tar xf $CWD/runtimes-$VERSION.src.tar.xz || exit 1
+mv runtimes-${VERSION}.src/cmake/Modules/* cmake/Modules || exit 1
+rm -r runtimes-${VERSION}.src
rm -rf $PKGNAM-${VERSION}.src $PKGNAM-${VERSION}
echo "Extracting $CWD/$PKGNAM-$VERSION.src.tar.xz..."
@@ -182,9 +179,8 @@ if [ -f ./tools/lldb/source/Utility/CMakeLists.txt ]; then
fi
fi
-# These files are not present for some reason, but they were found in a git
-# pull of the entire project:
-cp -a $CWD/missing-runtime-modules/*.cmake ../cmake/Modules/
+# Oops, the rc tag was left in with the 18.1.0 release:
+zcat $CWD/llvm.wrong.LLVM_LIBDIR_SUFFIX.patch.gz | patch -p1 --verbose || exit 1
# These hackish links seem to be required...
cd ..
@@ -243,6 +239,7 @@ cd build
-DCOMPILER_RT_BUILD_LIBFUZZER=OFF \
-DCLANG_DEFAULT_PIE_ON_LINUX=ON \
-DLIBCXX_ENABLE_ABI_LINKER_SCRIPT=ON \
+ -DLIBCXXABI_USE_LLVM_UNWINDER=OFF \
$CLANGD \
.. || exit 1
@@ -288,12 +285,15 @@ python3 -m compileall "$PKG/usr/lib$LIBDIRSUFFIX/python${PY3}/site-packages/clan
python3 -O -m compileall "$PKG/usr/lib$LIBDIRSUFFIX/python${PY3}/site-packages/clang"
python -m compileall "$PKG/usr/lib$LIBDIRSUFFIX/python${PY2}/site-packages/lldb"
python -O -m compileall "$PKG/usr/lib$LIBDIRSUFFIX/python${PY2}/site-packages/lldb"
-python -m compileall "$PKG/usr/share/scan-view"
-python -O -m compileall "$PKG/usr/share/scan-view"
-python -m compileall "$PKG/usr/share/clang"
-python -O -m compileall "$PKG/usr/share/clang"
-python -m compileall "$PKG/usr/share/opt-viewer"
-python -O -m compileall "$PKG/usr/share/opt-viewer"
+python3 -m compileall "$PKG/usr/share/scan-view"
+python3 -O -m compileall "$PKG/usr/share/scan-view"
+python3 -m compileall "$PKG/usr/share/clang"
+python3 -O -m compileall "$PKG/usr/share/clang"
+python3 -m compileall "$PKG/usr/share/opt-viewer"
+python3 -O -m compileall "$PKG/usr/share/opt-viewer"
+
+# Nevermind, we're not shipping this python2 crap:
+rm -rf $PKG/usr/lib$LIBDIRSUFFIX/python${PY2}
# Move man page directory:
mv $PKG/usr/share/man $PKG/usr/