summaryrefslogtreecommitdiffstats
path: root/source/d/python2/python2.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'source/d/python2/python2.SlackBuild')
-rwxr-xr-xsource/d/python2/python2.SlackBuild106
1 files changed, 66 insertions, 40 deletions
diff --git a/source/d/python2/python2.SlackBuild b/source/d/python2/python2.SlackBuild
index c360fd8a8..5ffaedb88 100755
--- a/source/d/python2/python2.SlackBuild
+++ b/source/d/python2/python2.SlackBuild
@@ -97,6 +97,17 @@ find . \
# Enable built-in SQLite module to load extensions
sed -i "/SQLITE_OMIT_LOAD_EXTENSION/d" setup.py
+# If there's no pip2 on the system, assume python2 is not installed and
+# bootstrap from scratch:
+if [ ! -x /usr/bin/pip2 ]; then
+ # If system we're building on already has Python2 with pip in site-packages,
+ # ignore it and install pip anyway.
+ sed -i 's|\("install",\)|\1 "--ignore-installed",|' Lib/ensurepip/__init__.py
+ ENSUREPIP="--with-ensurepip"
+else
+ ENSUREPIP="--without-ensurepip"
+fi
+
./configure \
--prefix=/usr \
--libdir=/usr/lib${LIBDIRSUFFIX} \
@@ -108,7 +119,7 @@ sed -i "/SQLITE_OMIT_LOAD_EXTENSION/d" setup.py
--enable-unicode=ucs4 \
--with-system-expat \
--with-system-ffi \
- --without-ensurepip \
+ $ENSUREPIP \
--build=$ARCH-slackware-linux || exit 1
make $NUMJOBS || make || exit 1
@@ -122,44 +133,13 @@ rm -f $PKG/usr/bin/2to3
rm -f $PKG/usr/bin/python
rm -f $PKG/usr/bin/python-config
-# Bundle the very last pip for python2:
-tar xf $CWD/pip-20.3.tar.lz || exit 1
-cd pip-20.3
-fix_perms
-python2 setup.py install --root=$PKG || exit 1
# Don't package this. We want /usr/bin/pip in the main python-pip package to be
# the python3 version:
rm -f $PKG/usr/bin/pip
-mkdir -p $PKG/usr/doc/$PKGNAM-$VERSION/pip-20.3
-cp -a *.txt PKG-INFO README.rst \
- $PKG/usr/doc/$PKGNAM-$VERSION/pip-20.3
-find $PKG/usr/doc/$PKGNAM-$VERSION/pip-20.3 -type f -exec chmod 0644 {} \+
-cd ..
-# Bundle the very last setuptools for python2:
-tar xf $CWD/setuptools-44.1.1.tar.lz || exit 1
-cd setuptools-44.1.1
-fix_perms
-# Install setuptools to the system if it's not there:
-if [ ! -d /usr/lib${LIBDIRSUFFIX}/python2.7/site-packages/setuptools/version.py ]; then
- python2 setup.py install --root=/ || exit 1
-fi
-python2 setup.py install --root=$PKG || exit 1
# It's tempting to get rid of this entirely, but we'll leave the -2.7 versioned
# binary:
rm -f $PKG/usr/bin/easy_install
-mkdir -p $PKG/usr/doc/$PKGNAM-$VERSION/setuptools-44.1.1
-cp -a CHANGES.rst PKG-INFO README.rst docs/*.txt \
- $PKG/usr/doc/$PKGNAM-$VERSION/setuptools-44.1.1
-find $PKG/usr/doc/$PKGNAM-$VERSION/setuptools-44.1.1 -type f -exec chmod 0644 {} \+
-# If there's a CHANGES.rst, installing at least part of the recent history
-# is useful, but don't let it get totally out of control:
-if [ -r CHANGES.rst ]; then
- DOCSDIR=$(echo $PKG/usr/doc/${PKGNAM}-$VERSION/setuptools-44.1.1)
- cat CHANGES.rst | head -n 1000 > $DOCSDIR/CHANGES.rst
- touch -r CHANGES.rst $DOCSDIR/CHANGES.rst
-fi
-cd ..
# Install some python-demo files:
mkdir -p $PKG/usr/doc/python2-$VERSION
@@ -190,13 +170,6 @@ chown -R root:root $PKG/usr/doc/python2-$VERSION
find . -perm 750 -exec chmod 755 "{}" \+
)
-( cd $PKG
- find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | \
- xargs strip --strip-unneeded 2> /dev/null
- find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | \
- xargs strip --strip-unneeded 2> /dev/null
-)
-
( cd $PKG/usr/man
find . -type f -exec gzip -9 {} \+
for i in $(find . -type l) ; do ln -s $(readlink $i).gz $i.gz ; rm $i ; done
@@ -208,9 +181,62 @@ chown -R root:root $PKG/usr/doc/python2-$VERSION
fi
)
+# If python2 isn't already installed, we need to bootstrap it to the system now:
+if [ ! -x /usr/bin/pip2 ]; then
+ ( cd $PKG
+ echo "Bootstrapping..."
+ tar cf - . | ( cd / ; tar xf - )
+ )
+fi
+
+# Bundle the very last pip for python2:
+tar xf $CWD/pip-20.3.tar.lz || exit 1
+cd pip-20.3
+fix_perms
+python2 setup.py install --root=$PKG || exit 1
+# Don't package this. We want /usr/bin/pip in the main python-pip package to be
+# the python3 version:
+rm -f $PKG/usr/bin/pip
+mkdir -p $PKG/usr/doc/$PKGNAM-$VERSION/pip-20.3
+cp -a *.txt PKG-INFO README.rst \
+ $PKG/usr/doc/$PKGNAM-$VERSION/pip-20.3
+find $PKG/usr/doc/$PKGNAM-$VERSION/pip-20.3 -type f -exec chmod 0644 {} \+
+cd ..
+
+# Bundle the very last setuptools for python2:
+tar xf $CWD/setuptools-44.1.1.tar.lz || exit 1
+cd setuptools-44.1.1
+fix_perms
+# Install setuptools to the system if it's not there:
+if [ ! -d /usr/lib${LIBDIRSUFFIX}/python2.7/site-packages/setuptools/version.py ]; then
+ python2 setup.py install --root=/ || exit 1
+fi
+python2 setup.py install --root=$PKG || exit 1
+# It's tempting to get rid of this entirely, but we'll leave the -2.7 versioned
+# binary:
+rm -f $PKG/usr/bin/easy_install
+mkdir -p $PKG/usr/doc/$PKGNAM-$VERSION/setuptools-44.1.1
+cp -a CHANGES.rst PKG-INFO README.rst docs/*.txt \
+ $PKG/usr/doc/$PKGNAM-$VERSION/setuptools-44.1.1
+find $PKG/usr/doc/$PKGNAM-$VERSION/setuptools-44.1.1 -type f -exec chmod 0644 {} \+
+# If there's a CHANGES.rst, installing at least part of the recent history
+# is useful, but don't let it get totally out of control:
+if [ -r CHANGES.rst ]; then
+ DOCSDIR=$(echo $PKG/usr/doc/${PKGNAM}-$VERSION/setuptools-44.1.1)
+ cat CHANGES.rst | head -n 1000 > $DOCSDIR/CHANGES.rst
+ touch -r CHANGES.rst $DOCSDIR/CHANGES.rst
+fi
+cd ..
+
+( cd $PKG
+ find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null
+ find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null
+)
+
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
/sbin/makepkg -l y -c n $TMP/python2-$VERSION-$ARCH-$BUILD.txz
-