summaryrefslogtreecommitdiffstats
path: root/deps/libdbusmenu-qt5/libdbusmenu-qt5.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to '')
-rwxr-xr-xdeps/libdbusmenu-qt5/libdbusmenu-qt5.SlackBuild (renamed from deps/attica/attica.SlackBuild)37
1 files changed, 24 insertions, 13 deletions
diff --git a/deps/attica/attica.SlackBuild b/deps/libdbusmenu-qt5/libdbusmenu-qt5.SlackBuild
index 9b98685..57768a6 100755
--- a/deps/attica/attica.SlackBuild
+++ b/deps/libdbusmenu-qt5/libdbusmenu-qt5.SlackBuild
@@ -1,9 +1,9 @@
#!/bin/sh
-# Copyright 2009, 2010, 2011 Eric Hameleers, Eindhoven, NL
-# Copyright 2009, 2010, 2011 Patrick J. Volkerding, Sebeka, MN, USA
+# Copyright 2010, 2011, 2012, 2014 Eric Hameleers, Eindhoven, The Netherlands
+# Copyright 2010, 2011, 2012 Patrick J. Volkerding, Sebeka, MN, USA
# All rights reserved.
-#
+
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
#
@@ -22,7 +22,14 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-PKGNAM=attica
+# This project has moved to https://launchpad.net/libdbusmenu-qt
+# Get the latest code with:
+# bzr branch lp:libdbusmenu-qt
+#
+# Get version number from
+# grep dbusmenu_qt_VERSION dbusmenu-qt/CMakeLists.txt
+
+PKGNAM=libdbusmenu-qt5
VERSION=${VERSION:-$(echo $PKGNAM-*.tar.?z* | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
BUILD=${BUILD:-1}
@@ -49,9 +56,6 @@ elif [ "$ARCH" = "s390" ]; then
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
LIBDIRSUFFIX="64"
-elif [ "$ARCH" = "armv7hl" ]; then
- SLKCFLAGS="-O2 -march=armv7-a -mfpu=vfpv3-d16"
- LIBDIRSUFFIX=""
else
SLKCFLAGS="-O2"
LIBDIRSUFFIX=""
@@ -67,6 +71,7 @@ cd $TMP
rm -rf $PKGNAM-$VERSION
tar xvf $CWD/$PKGNAM-$VERSION.tar.?z* || exit 1
cd $PKGNAM-$VERSION || exit 1
+
chown -R root:root .
find . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
@@ -74,30 +79,36 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
+# Switch the two booleans USE_QT4 and USE_QT5 to build a Qt4 version instead.
+
mkdir -p build
cd build
- QTDIR=/usr/lib${LIBDIRSUFFIX}/qt \
+ QTDIR=/usr/lib${LIBDIRSUFFIX}/qt5 \
PATH=$QTDIR/bin:$PATH \
cmake \
- $KDE_OPT_ARGS \
-DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
-DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DMAN_INSTALL_DIR=/usr/man \
- -DSYSCONF_INSTALL_DIR=/etc \
-DLIB_SUFFIX=${LIBDIRSUFFIX} \
+ -DUSE_QT4:BOOL=FALSE \
+ -DUSE_QT5:BOOL=TRUE \
..
make $NUMJOBS || make || exit 1
make install DESTDIR=$PKG || exit 1
-cd -
+cd ..
find $PKG | xargs file | grep -e "executable" -e "shared object" \
| grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
mkdir -p $PKG/usr/doc/$PKGNAM-$VERSION
-cp -a AUTHORS* COPYING* README* \
+cp -a \
+ COPYING NEWS README \
$PKG/usr/doc/$PKGNAM-$VERSION
+mkdir -p $PKG/usr/doc/$PKGNAM-$VERSION/doc
+mv $PKG/usr/share/doc/dbusmenu-qt/* $PKG/usr/doc/$PKGNAM-$VERSION/doc
+rm -rf $PKG/usr/share/doc
+
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc