summaryrefslogtreecommitdiffstats
path: root/deps/libdbusmenu-qt5/libdbusmenu-qt5.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'deps/libdbusmenu-qt5/libdbusmenu-qt5.SlackBuild')
-rwxr-xr-xdeps/libdbusmenu-qt5/libdbusmenu-qt5.SlackBuild42
1 files changed, 24 insertions, 18 deletions
diff --git a/deps/libdbusmenu-qt5/libdbusmenu-qt5.SlackBuild b/deps/libdbusmenu-qt5/libdbusmenu-qt5.SlackBuild
index 103e251..a16f439 100755
--- a/deps/libdbusmenu-qt5/libdbusmenu-qt5.SlackBuild
+++ b/deps/libdbusmenu-qt5/libdbusmenu-qt5.SlackBuild
@@ -1,6 +1,6 @@
#!/bin/sh
-# Copyright 2010, 2011, 2012, 2014, 2015, 2017 Eric Hameleers, Eindhoven, The Netherlands
+# Copyright 2010, 2011, 2012, 2014, 2015, 2017, 2020 Eric Hameleers, Eindhoven, The Netherlands
# Copyright 2010, 2011, 2012 Patrick J. Volkerding, Sebeka, MN, USA
# All rights reserved.
@@ -29,25 +29,37 @@
# Get version number from
# grep dbusmenu_qt_VERSION dbusmenu-qt/CMakeLists.txt
+cd $(dirname $0) ; CWD=$(pwd)
+
PKGNAM=libdbusmenu-qt5
SRCNAM=libdbusmenu-qt
VERSION=${VERSION:-0.9.3+16.04.20160218}
-BUILD=${BUILD:-1}
-
-NUMJOBS=${NUMJOBS:--j7}
+BUILD=${BUILD:-2}
# Automatically determine the architecture we're building on:
-MARCH=$( uname -m )
if [ -z "$ARCH" ]; then
- case "$MARCH" in
- i?86) export ARCH=i586 ;;
- armv7hl) export ARCH=$MARCH ;;
- arm*) export ARCH=arm ;;
+ case "$(uname -m)" in
+ i?86) ARCH=i586 ;;
+ arm*) readelf /usr/bin/file -A | egrep -q "Tag_CPU.*[4,5]" && ARCH=arm || ARCH=armv7hl ;;
# Unless $ARCH is already set, use uname -m for all other archs:
- *) export ARCH=$MARCH ;;
+ *) ARCH=$(uname -m) ;;
esac
+ export ARCH
+fi
+
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PKGNAM-$VERSION-$ARCH-$BUILD.txz"
+ exit 0
fi
+NUMJOBS=${NUMJOBS:-" -j$(expr $(nproc) + 1) "}
+
+TMP=${TMP:-/tmp}
+PKG=$TMP/package-$PKGNAM
+
if [ "$ARCH" = "i486" ]; then
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
LIBDIRSUFFIX=""
@@ -65,10 +77,6 @@ else
LIBDIRSUFFIX=""
fi
-CWD=$(pwd)
-TMP=${TMP:-/tmp}
-PKG=$TMP/package-$PKGNAM
-
rm -rf $PKG
mkdir -p $TMP $PKG
cd $TMP
@@ -79,11 +87,9 @@ cd $SRCNAM-$VERSION || exit 1
chown -R root:root .
find . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
+ -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-# Switch the two booleans USE_QT4 and USE_QT5 to build a Qt4 version instead.
+ -exec chmod 644 {} \+
mkdir -p build
cd build