summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Alexander Verbovetsky <alik@ejik.org>2023-05-05 20:49:18 +0100
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2023-05-06 08:28:28 +0700
commitcee0ae80b77f2d9846c023da02b85b1a3b6afbef (patch)
tree8548e77ac176eea14bf58750aeb3ed8962e460d9
parentebf6b6e1c5bc703f76d0601673d3af5d8530cf41 (diff)
downloadslackbuilds-cee0ae80b77f2d9846c023da02b85b1a3b6afbef.tar.gz
slackbuilds-cee0ae80b77f2d9846c023da02b85b1a3b6afbef.tar.xz
python/python2-neovim: Added (Python client for Neovim)
Signed-off-by: bedlam <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/python2-neovim/README3
-rw-r--r--python/python2-neovim/python2-neovim.SlackBuild94
-rw-r--r--python/python2-neovim/python2-neovim.info10
-rw-r--r--python/python2-neovim/slack-desc19
4 files changed, 126 insertions, 0 deletions
diff --git a/python/python2-neovim/README b/python/python2-neovim/README
new file mode 100644
index 0000000000..821d042347
--- /dev/null
+++ b/python/python2-neovim/README
@@ -0,0 +1,3 @@
+python-neovim is a Python client for Neovim. It implements support
+for Python plugins and also works as a library for connecting to and
+scripting Neovim processes through its msgpack-rpc API.
diff --git a/python/python2-neovim/python2-neovim.SlackBuild b/python/python2-neovim/python2-neovim.SlackBuild
new file mode 100644
index 0000000000..4f838843f0
--- /dev/null
+++ b/python/python2-neovim/python2-neovim.SlackBuild
@@ -0,0 +1,94 @@
+#!/bin/bash
+
+# Slackware build script for python2-neovim
+
+# Copyright 2017-2021 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
+# Copyright 2022-2023, Alexander Verbovetsky, Moscow, Russia
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=python2-neovim
+SRCNAM=pynvim
+VERSION=${VERSION:-0.4.3}
+BUILD=${BUILD:-2}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python2 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README.md $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/python2-neovim/python2-neovim.info b/python/python2-neovim/python2-neovim.info
new file mode 100644
index 0000000000..632ab27a6f
--- /dev/null
+++ b/python/python2-neovim/python2-neovim.info
@@ -0,0 +1,10 @@
+PRGNAM="python2-neovim"
+VERSION="0.4.3"
+HOMEPAGE="https://github.com/neovim/pynvim"
+DOWNLOAD="https://github.com/neovim/pynvim/archive/0.4.3/pynvim-0.4.3.tar.gz"
+MD5SUM="b7370a5b3d2177d2b97ca48695ba1ae3"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="greenlet msgpack-python"
+MAINTAINER="Alexander Verbovetsky"
+EMAIL="alik@ejik.org"
diff --git a/python/python2-neovim/slack-desc b/python/python2-neovim/slack-desc
new file mode 100644
index 0000000000..693e6a961e
--- /dev/null
+++ b/python/python2-neovim/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python2-neovim: python2-neovim (Python client for Neovim)
+python2-neovim:
+python2-neovim: python2-neovim is a Python client for Neovim.
+python2-neovim:
+python2-neovim:
+python2-neovim:
+python2-neovim:
+python2-neovim:
+python2-neovim:
+python2-neovim:
+python2-neovim: