summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Jeremy Hansen <jebrhansen+github@gmail.com>2023-09-11 12:57:55 -0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2023-09-17 00:10:30 +0700
commitb029d6296c557442ee4b959a8bd8d55613f05afe (patch)
tree94441068a179ce2a5c3f99a23dd4ad4bebecd2af
parent5df7826f48c8eefc2a5ec39d6673dce3a1d89b92 (diff)
downloadslackbuilds-b029d6296c557442ee4b959a8bd8d55613f05afe.tar.gz
slackbuilds-b029d6296c557442ee4b959a8bd8d55613f05afe.tar.xz
python/cppy: Updated for version 1.2.1.
Signed-off-by: Andrew Clemons <andrew.clemons@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/cppy/README3
-rw-r--r--python/cppy/cppy.SlackBuild7
-rw-r--r--python/cppy/cppy.info8
3 files changed, 10 insertions, 8 deletions
diff --git a/python/cppy/README b/python/cppy/README
index 0e23cc9ed6..f36f1b7715 100644
--- a/python/cppy/README
+++ b/python/cppy/README
@@ -2,6 +2,3 @@ cppy is a small C++ header library which makes it easier to write Python
extension modules. The primary feature is a PyObject smart pointer which
automatically handles reference counting and provides convenience
methods for performing common object operations.
-
-cppy 1.2.0 is the last possible version for Slackware 15.0. Newer
-versions require a newer python-setuptools.
diff --git a/python/cppy/cppy.SlackBuild b/python/cppy/cppy.SlackBuild
index 60dd98223d..bc15f9148a 100644
--- a/python/cppy/cppy.SlackBuild
+++ b/python/cppy/cppy.SlackBuild
@@ -3,6 +3,7 @@
# Slackware build script for cppy
# Copyright 2022-2023 Isaac Yu <isaacyu@protonmail.com>
+# Copyright 2023 Jeremy Hansen <jebrhansen+SBo@gmail.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification,
@@ -26,7 +27,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=cppy
-VERSION=${VERSION:-1.2.0}
+VERSION=${VERSION:-1.2.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -63,6 +64,10 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+# Use newer, non-stock setuptools due to package requirements
+# Requres python/python3-setuptools-opt build-time dependency
+export PYTHONPATH=/opt/python3.9/site-packages/
+
python3 setup.py install --root $PKG
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
diff --git a/python/cppy/cppy.info b/python/cppy/cppy.info
index 3a138a858e..603bdd1174 100644
--- a/python/cppy/cppy.info
+++ b/python/cppy/cppy.info
@@ -1,10 +1,10 @@
PRGNAM="cppy"
-VERSION="1.2.0"
+VERSION="1.2.1"
HOMEPAGE="https://github.com/nucleic/cppy"
-DOWNLOAD="https://github.com/nucleic/cppy/releases/download/1.2.0/cppy-1.2.0.tar.gz"
-MD5SUM="d5790863221465f259f751252a259654"
+DOWNLOAD="https://github.com/nucleic/cppy/releases/download/1.2.1/cppy-1.2.1.tar.gz"
+MD5SUM="7c1f825c43dd66454440932a35b9969c"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES=""
+REQUIRES="python3-setuptools-opt"
MAINTAINER="Jeremy Hansen"
EMAIL="jebrhansen+SBo@gmail.com"