summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Dimitris Zlatanidis <d.zlatanidis@gmail.com>2024-02-15 21:34:59 +0200
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2024-02-17 09:07:16 +0700
commit7ebd36804cc9959e87420e19afc451abcf8ab857 (patch)
tree759b110ea427b674bd29cd9e9940d8895d0bc13e
parentb48b38291be1dcab3fb70104577e4afc68d3e7c1 (diff)
downloadslackbuilds-7ebd36804cc9959e87420e19afc451abcf8ab857.tar.gz
slackbuilds-7ebd36804cc9959e87420e19afc451abcf8ab857.tar.xz
python/lockfile: Removed (splitted to python2 & python3).
Signed-off-by: Dimitris Zlatanidis <d.zlatanidis@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/lockfile/README12
-rw-r--r--python/lockfile/lockfile.SlackBuild87
-rw-r--r--python/lockfile/lockfile.info10
-rw-r--r--python/lockfile/slack-desc19
4 files changed, 0 insertions, 128 deletions
diff --git a/python/lockfile/README b/python/lockfile/README
deleted file mode 100644
index 83f170d7c8..0000000000
--- a/python/lockfile/README
+++ /dev/null
@@ -1,12 +0,0 @@
-The lockfile package exports a LockFile class which provides a simple
-API for locking files.
-
-Unlike the Windows msvcrt.locking function, the fcntl.lockf and flock
-functions, and the deprecated posixfile module, the API is identical
-across both Unix (including Linux and Mac) and Windows platforms.
-
-This package is version 0.8 due to some API breakage in 0.9+
-
-To build for Python 3:
- # PYTHON=python3 ./lockfile.SlackBuild
-
diff --git a/python/lockfile/lockfile.SlackBuild b/python/lockfile/lockfile.SlackBuild
deleted file mode 100644
index 0c647cca62..0000000000
--- a/python/lockfile/lockfile.SlackBuild
+++ /dev/null
@@ -1,87 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for lockfile
-
-# Copyright 2013 klaatu at member.fsf.org
-#
-# GNU All-Permissive License
-# Copying and distribution of this file, with or without modification,
-# are permitted in any medium without royalty provided the copyright
-# notice and this notice are preserved. This file is offered as-is,
-# without any warranty.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=lockfile
-VERSION=${VERSION:-0.8}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-PYTHON=${PYTHON:-python}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-$PYTHON setup.py install --root=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- PKG-INFO MANIFEST README RELEASE-NOTES \
- $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/lockfile/lockfile.info b/python/lockfile/lockfile.info
deleted file mode 100644
index d098e0c76e..0000000000
--- a/python/lockfile/lockfile.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="lockfile"
-VERSION="0.8"
-HOMEPAGE="https://pypi.python.org/pypi/lockfile/0.8"
-DOWNLOAD="http://ponce.cc/slackware/sources/repo/lockfile-0.8.tar.gz"
-MD5SUM="2d515e19eb6f69d6ed711cbbafdec7ef"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Klaatu"
-EMAIL="klaatu@member.nospam.fsf.org"
diff --git a/python/lockfile/slack-desc b/python/lockfile/slack-desc
deleted file mode 100644
index f1967a2d52..0000000000
--- a/python/lockfile/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-lockfile: lockfile (API for locking files)
-lockfile:
-lockfile: The lockfile package exports a LockFile class which provides a
-lockfile: simple API for locking files.
-lockfile:
-lockfile: https://pypi.python.org/pypi/lockfile/0.8
-lockfile:
-lockfile:
-lockfile:
-lockfile:
-lockfile: