summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Giancarlo Dessì <slack@giand.it>2023-06-09 22:36:19 +0100
committer bedlam <dave@slackbuilds.org>2023-06-09 22:36:19 +0100
commit739993cb05008eb3521f41d88dafa815b60e171f (patch)
treefa111430e92854cbf253b5effce026526590331c
parent36f30dd9af8d625701526fda67a28fe41b2b7827 (diff)
downloadslackbuilds-739993cb05008eb3521f41d88dafa815b60e171f.tar.gz
slackbuilds-739993cb05008eb3521f41d88dafa815b60e171f.tar.xz
graphics/FotoKilof: Updated for version 4.3.3.
Signed-off-by: bedlam <dave@slackbuilds.org>
-rw-r--r--graphics/FotoKilof/FotoKilof.SlackBuild22
-rw-r--r--graphics/FotoKilof/FotoKilof.info6
-rw-r--r--graphics/FotoKilof/README3
-rw-r--r--graphics/FotoKilof/move_fotokilof-to-__main__.patch94
4 files changed, 22 insertions, 103 deletions
diff --git a/graphics/FotoKilof/FotoKilof.SlackBuild b/graphics/FotoKilof/FotoKilof.SlackBuild
index af907a449e..6e0cc337e7 100644
--- a/graphics/FotoKilof/FotoKilof.SlackBuild
+++ b/graphics/FotoKilof/FotoKilof.SlackBuild
@@ -25,7 +25,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=FotoKilof
-VERSION=${VERSION:-4.3.2}
+VERSION=${VERSION:-4.3.3}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -76,17 +76,27 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-# Global patch to allow the build from source without postinstall issues
-# occurred in Slackware: fotokilof.py must be moved to __main__.py
-# Thanks to Team-TL aka Tomasz Łuczak for the support
-patch -p0 < $CWD/move_fotokilof-to-__main__.patch
-mv ./fotokilof/fotokilof.py ./fotokilof/__main__.py
+# compile MO files, for available localization
+cd fotokilof/locale/
+echo "Build translations..."
+for I in ??; do
+ cd $I/LC_MESSAGES
+ if [ -e fotokilof.po ]; then
+ msgfmt fotokilof.po -o fotokilof.mo
+ fi
+ cd ../../
+done
+cd ../../
python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+# Since the python install process does not install localization, at the moment
+# we make this manually (a patch in some python scripts of source should be required)
+cp -a fotokilof/locale $PKG/usr/lib${LIBDIRSUFFIX}/python3.9/site-packages/fotokilof
+
#Install the application icon and desktop entry
mkdir -p $PKG/usr/share/icons/hicolor/256x256/apps
cp -a $CWD/icon.png $PKG/usr/share/icons/hicolor/256x256/apps/fotokilof.png
diff --git a/graphics/FotoKilof/FotoKilof.info b/graphics/FotoKilof/FotoKilof.info
index 16699608e6..f33521d203 100644
--- a/graphics/FotoKilof/FotoKilof.info
+++ b/graphics/FotoKilof/FotoKilof.info
@@ -1,8 +1,8 @@
PRGNAM="FotoKilof"
-VERSION="4.3.2"
+VERSION="4.3.3"
HOMEPAGE="https://github.com/TeaM-TL/FotoKilof"
-DOWNLOAD="https://github.com/TeaM-TL/FotoKilof/archive/4.3.2/FotoKilof-4.3.2.tar.gz"
-MD5SUM="36ee5d7e6db63772cf536d496b16e87d"
+DOWNLOAD="https://github.com/TeaM-TL/FotoKilof/archive/4.3.3/FotoKilof-4.3.3.tar.gz"
+MD5SUM="8a25838b984c7935b4823894c3c71fe6"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="python-wand ttkbootstrap"
diff --git a/graphics/FotoKilof/README b/graphics/FotoKilof/README
index 167cd0441d..cf14f89a93 100644
--- a/graphics/FotoKilof/README
+++ b/graphics/FotoKilof/README
@@ -21,3 +21,6 @@ of FotoKilof please see the home page of the project.
FotoKilof is written in Python and its GUI uses tkinter (already
included in the Slackware's Python 3 package), the python theme engine
for Tk, so your system must have the Tk/Tcl platform installed.
+
+The graphic interface supports two different themes: Light (default)
+and Dark. F2 key allows to switch between them at any time.
diff --git a/graphics/FotoKilof/move_fotokilof-to-__main__.patch b/graphics/FotoKilof/move_fotokilof-to-__main__.patch
deleted file mode 100644
index 5771767cbd..0000000000
--- a/graphics/FotoKilof/move_fotokilof-to-__main__.patch
+++ /dev/null
@@ -1,94 +0,0 @@
-This patch solves the issues in the build from source from Slackware
-It is extracted from the last changes committed in the current git branch
-by the author Team-TL.
-Thanks to Team-TL (aka Tomasz Łuczak)
-
---- fotokilof/fotokilof.sh 2023-04-26 21:00:46.000000000 +0200
-+++ fotokilof/fotokilof.sh 2023-06-01 19:05:41.388973243 +0200
-@@ -2,5 +2,5 @@
-
- # MYPATH - path to FotoKilof python source
--MAIN=fotokilof.py
-+MAIN=__main__.py
- MYPATH="${0%/*}"
- cd $MYPATH
-
---- ./fotokilof/__init__.py 2023-04-26 21:00:46.000000000 +0200
-+++ ./fotokilof/__init__.py 2023-06-01 19:04:14.564973735 +0200
-@@ -2,5 +2,5 @@
-
- """
--Copyright (c) 2019-2022 Tomasz Łuczak, TeaM-TL
-+Copyright (c) 2019-2023 Tomasz Łuczak, TeaM-TL
-
- Permission is hereby granted, free of charge, to any person obtaining a copy
-
---- ./setup.py 2023-04-26 21:00:46.000000000 +0200
-+++ ./setup.py 2023-06-01 19:01:40.430974610 +0200
-@@ -1,3 +1,3 @@
--import setuptools
-+from setuptools import setup, find_packages
-
- with open("README.md", "r") as fh:
-@@ -7,5 +7,5 @@
- with open("fotokilof/version.py") as fp:
- exec(fp.read(), pkg_vars)
--setuptools.setup(
-+setup(
- name=pkg_vars['__appname__'],
- version=pkg_vars['__version__'],
-@@ -17,5 +17,4 @@
- long_description=long_description,
- long_description_content_type="text/markdown",
-- packages=setuptools.find_packages(),
- license="MIT",
- classifiers=[
-@@ -26,11 +25,12 @@
- ],
- python_requires='>=3.6',
-- install_requires=['pillow','wand','ttkbootstrap'],
-- entry_points = {
-- "gui_scripts": [
-- "fotokilof = fotokilof:__main__",
-- ]
-- },
- include_package_data=True,
-+ packages=find_packages(),
-+ install_requires=['pillow','wand','ttkbootstrap'],
-+# entry_points = {
-+# "gui_scripts": [
-+# "fotokilof = fotokilof:__main__",
-+# ]
-+# },
- )
-
---- ./scripts/0_pypi_setuptools.sh 2023-04-26 21:00:46.000000000 +0200
-+++ ./scripts/0_pypi_setuptools.sh 2023-06-01 19:07:20.691972680 +0200
-@@ -4,13 +4,8 @@
- rm -rf ../fotokilof/__pycache__
- CWD=`pwd`
--INITPY="fotokilof/__init__.py"
--MAINPY="fotokilof/fotokilof.py"
--MAIN__PY="fotokilof/__main__.py"
-
- echo "- PyPI ---"
-
- cd ..
--touch $INITPY
--mv $MAINPY $MAIN__PY
-
- # Python 3.8
-@@ -19,5 +14,4 @@
- python3 setup.py sdist bdist_wheel
-
--mv $MAIN__PY $MAINPY
- cd $CWD
-
---- ./MANIFEST.in 2023-04-26 21:00:46.000000000 +0200
-+++ ./MANIFEST.in 2023-06-01 19:00:41.446974944 +0200
-@@ -11,4 +11,4 @@
-
- # Include locale
--recursive-include fotokilof/locale *
-+recursive-include locale *.mo
-