summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Isaac Yu <isaacyu1@isaacyu1.com>2022-10-02 22:37:47 -0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2022-10-08 09:12:53 +0700
commit72949eb23c73432f768b8b9d3e544160275697d1 (patch)
tree0f5f10361777637e353c28eb559f958f14ccc7da
parent9e814b183590eb31a82c12b2f0ca858b338ef6ba (diff)
downloadslackbuilds-72949eb23c73432f768b8b9d3e544160275697d1.tar.gz
slackbuilds-72949eb23c73432f768b8b9d3e544160275697d1.tar.xz
python/terminado: Updated for version 0.16.0.
Signed-off-by: Andrew Clemons <andrew.clemons@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/terminado/terminado.SlackBuild23
-rw-r--r--python/terminado/terminado.info8
2 files changed, 8 insertions, 23 deletions
diff --git a/python/terminado/terminado.SlackBuild b/python/terminado/terminado.SlackBuild
index 37eacb5f5a..80ddb898c7 100644
--- a/python/terminado/terminado.SlackBuild
+++ b/python/terminado/terminado.SlackBuild
@@ -26,7 +26,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=terminado
-VERSION=${VERSION:-0.15.0}
+VERSION=${VERSION:-0.16.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -80,29 +80,14 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-# Use this setup.py shim:
-cat << EOF > setup.py
-from setuptools import setup, find_packages
-setup(name='${PRGNAM}',
- version='${VERSION}',
- packages=find_packages(),
- package_data={'': ['*'], 'terminado': ['_static/*']},
- install_requires=["ptyprocess;os_name!='nt'", "pywinpty>=1.1.0;os_name=='nt'", "tornado>=6.1.0"],
- extras_require={'test': ['pytest']},
-)
-EOF
-
-# With the shim, it's a good idea to use "unshare -n" to prevent downloading
-# anything extra:
-unshare -n python3 setup.py install --root=$PKG || exit 1
+python3 -m build --no-isolation
+python3 -m installer -d "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- LICENSE PKG-INFO README.rst \
- $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README.rst $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/python/terminado/terminado.info b/python/terminado/terminado.info
index 40f1a6f531..69ee1acad4 100644
--- a/python/terminado/terminado.info
+++ b/python/terminado/terminado.info
@@ -1,10 +1,10 @@
PRGNAM="terminado"
-VERSION="0.15.0"
+VERSION="0.16.0"
HOMEPAGE="https://github.com/jupyter/terminado"
-DOWNLOAD="https://files.pythonhosted.org/packages/source/t/terminado/terminado-0.15.0.tar.gz"
-MD5SUM="e3fe92b48b3885ffa19b9890ed41578f"
+DOWNLOAD="https://files.pythonhosted.org/packages/source/t/terminado/terminado-0.16.0.tar.gz"
+MD5SUM="78c1f4bdbadc6d0b28e17d2e4911c056"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="python3-ptyprocess python3-tornado"
+REQUIRES="python3-ptyprocess python3-tornado python3-hatchling"
MAINTAINER="Isaac Yu"
EMAIL="isaacyu1@isaacyu1.com"