summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Tonus <tonus1@free.fr>2023-01-20 05:19:58 +0000
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2023-01-21 10:22:04 +0700
commit5a3d8e493b8878969c3f45f121395a2ba49be7dc (patch)
tree081f7bcf3373b9f1752f565329f662a37c6de5ec
parent312a42178fb50fe8a8ed5f5e04dd77c091a5b43d (diff)
downloadslackbuilds-5a3d8e493b8878969c3f45f121395a2ba49be7dc.tar.gz
slackbuilds-5a3d8e493b8878969c3f45f121395a2ba49be7dc.tar.xz
python/python3-xlib: Added (X Library module for Python 3)
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/python3-xlib/README10
-rw-r--r--python/python3-xlib/python3-xlib.SlackBuild78
-rw-r--r--python/python3-xlib/python3-xlib.info10
-rw-r--r--python/python3-xlib/slack-desc19
4 files changed, 117 insertions, 0 deletions
diff --git a/python/python3-xlib/README b/python/python3-xlib/README
new file mode 100644
index 0000000000..93cefe5199
--- /dev/null
+++ b/python/python3-xlib/README
@@ -0,0 +1,10 @@
+The Python X Library is intended to be a fully functional X client
+library for Python programs. It is written entirely in Python, in
+contrast to earlier X libraries for Python which were interfaces to
+the C Xlib.
+
+This is possible to do since X client programs communicate with the X
+server via the X protocol. The communication takes place over TCP/IP,
+Unix sockets, DECnet or any other streaming network protocol. The C
+Xlib is merely an interface to this protocol, providing functions
+suitable for a C environment.
diff --git a/python/python3-xlib/python3-xlib.SlackBuild b/python/python3-xlib/python3-xlib.SlackBuild
new file mode 100644
index 0000000000..b031456d57
--- /dev/null
+++ b/python/python3-xlib/python3-xlib.SlackBuild
@@ -0,0 +1,78 @@
+#!/bin/bash
+# Slackware build script for python3-xlib
+
+# Copyright 2023 Tonus Paris
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=python3-xlib
+VERSION=${VERSION:-0.26}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+SRCNAM=${SRCNAM:-python-xlib}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -eu
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.bz2
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+ python3 setup.py install --root=$PKG
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a CHANGELOG.md LICENSE PKG-INFO README.rst TODO $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/python3-xlib/python3-xlib.info b/python/python3-xlib/python3-xlib.info
new file mode 100644
index 0000000000..952fd4a4ac
--- /dev/null
+++ b/python/python3-xlib/python3-xlib.info
@@ -0,0 +1,10 @@
+PRGNAM="python3-xlib"
+VERSION="0.26"
+HOMEPAGE="https://github.com/python-xlib/python-xlib"
+DOWNLOAD="https://github.com/python-xlib/python-xlib/releases/download/0.26/python-xlib-0.26.tar.bz2"
+MD5SUM="678871a692c5409a6d6b5aaaf7f6e60d"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Tonus"
+EMAIL="tonus1@free.fr"
diff --git a/python/python3-xlib/slack-desc b/python/python3-xlib/slack-desc
new file mode 100644
index 0000000000..a631a5cfd4
--- /dev/null
+++ b/python/python3-xlib/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python3-xlib: python3-xlib (X Library module for Python 3)
+python3-xlib:
+python3-xlib: The Python X Library is intended to be a fully functional X client
+python3-xlib: library for Python programs. It is written entirely in Python, in
+python3-xlib: contrast to earlier X libraries for Python which were interfaces to
+python3-xlib: the C Xlib. The communication takes place over TCP/IP, Unix sockets,
+python3-xlib: DECnet or any other streaming network protocol. The C Xlib is merely
+python3-xlib: an interface to this protocol, providing functions suitable for a C
+python3-xlib: environment.
+python3-xlib:
+python3-xlib: Homepage: https://github.com/python-xlib/python-xlib